【HDU】-2717-Catch That Cow(BFS)

Catch That Cow

Time Limit: 5000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 12312    Accepted Submission(s): 3824


Problem Description
Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?
 

Input
Line 1: Two space-separated integers: N and K
 

Output
Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
 

Sample Input
  
  
5 17
 

Sample Output
  
  
4
Hint
The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.


#include<cstdio>
#include<cstring>
#include<queue>
#include<algorithm>
#define MAX  200222
using namespace std;
int n,m;
int vis[MAX]; 
struct node
{
	int st,step;
}pr,ne;
int bfs()
{
	queue<node> q;
	pr.st=n;
	pr.step=0;
	q.push(pr);
	vis[pr.st]=1;
	while(1)
	{
		pr=q.front();
		q.pop();
		for(int i=1;i<=3;i++)		//三次,三种走法都走一次 
		{
			if(i==1)
			{
				ne.st=pr.st+1;
				if(ne.st==m)
					return pr.step+1;
				if(ne.st<MAX-200 && vis[ne.st]==0 )	
				{					//判断 ne.st是不是超出了必须放前面,不然vis[i]同时也超了,就会暴内存 
					vis[ne.st]=1;
					ne.step=pr.step+1;
					q.push(ne);
				}				
			}
			if(i==2)
			{
				ne.st=pr.st*2;
				if(ne.st==m)
					return ne.step;
				if(ne.st<MAX-200 && vis[ne.st]==0 )
				{
					vis[ne.st]=1;
					ne.step=pr.step+1;
					q.push(ne);
				}	
			}	
			if(i==3)
			{
				ne.st=pr.st-1;
				if(ne.st==m)
					return ne.step;
				if( ne.st<MAX-200 && ne.st>=0 && vis[ne.st]==0)		//既不可以出去,也不可以后退到 0以后 
				{
					vis[ne.st]=1;
					ne.step=pr.step+1;
					q.push(ne);
				}
			}
		}				
	}
}
int main()
{
	while(~scanf("%d %d",&n,&m))
	{
		memset(vis,0,sizeof(vis));		//一定要初始化,不然全部被标记后来就找不到了,while一直循环
		if(n>=m) 
			printf("%d\n",n-m);			//在人后面,直接减 
		else
		{
			int ans=bfs();
			printf("%d\n",ans);
		}
	} 
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值