【HDU】-1856-More is better(并查集)

More is better

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 327680/102400 K (Java/Others)
Total Submission(s): 24063    Accepted Submission(s): 8654


Problem Description
Mr Wang wants some boys to help him with a project. Because the project is rather complex,  the more boys come, the better it will be. Of course there are certain requirements.

Mr Wang selected a room big enough to hold the boys. The boy who are not been chosen has to leave the room immediately. There are 10000000 boys in the room numbered from 1 to 10000000 at the very beginning. After Mr Wang's selection any two of them who are still in this room should be friends (direct or indirect), or there is only one boy left. Given all the direct friend-pairs, you should decide the best way.
 

Input
The first line of the input contains an integer n (0 ≤ n ≤ 100 000) - the number of direct friend-pairs. The following n lines each contains a pair of numbers A and B separated by a single space that suggests A and B are direct friends. (A ≠ B, 1 ≤ A, B ≤ 10000000)
 

Output
The output in one line contains exactly one integer equals to the maximum number of boys Mr Wang may keep. 
 

Sample Input
  
  
4 1 2 3 4 5 6 1 6 4 1 2 3 4 5 6 7 8
 

Sample Output
  
  
4 2
Hint
A and B are friends(direct or indirect), B and C are friends(direct or indirect), then A and C are also friends(indirect). In the first sample {1,2,5,6} is the result. In the second sample {1,2},{3,4},{5,6},{7,8} are four kinds of answers.

题解:我也觉得数据太水了,用两个 for 循环开始写的时候就已经打算超时一次的,结果还是那么A了。

但是还是觉得不怎么好,师父用了下面的下面的方法,看起来不错,学学那后这么写。

我的:

#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
using namespace std;
#define CLR(a,b)  memset(a,b,sizeof(a))
int f[10000010];
int find(int x)
{
	if(x!=f[x])
		f[x]=find(f[x]);
	return f[x];
}
void join(int x,int y)
{
	int fx,fy;
	fx=find(x);
	fy=find(y);
	if(fx!=fy)
		f[fx]=fy;
}
int main()
{
	int n;
	while(~scanf("%d",&n))
	{
		if(n==0)					//没有任何一对是朋友就留 1 个人 
			printf("1\n");
		else
		{
			for(int i=1;i<=10000010;i++)
				f[i]=i;	
			int a,b,maxx=0;
			for(int i=1;i<=n;i++) 
			{
				scanf("%d %d",&a,&b);
				join(a,b);
				if(maxx<max(a,b))		//maxx记录最大值 
					maxx=max(a,b);
			}
			int num,ans=0;
			for(int i=1;i<=maxx;i++)
			{
				num=0;	
				if(f[i]==i)				//根节点 
				{
					for(int j=1;j<=maxx;j++)
					{
						if(i==find(f[j]))		//根相同 num++ 
							num++;
					}
				}					
				ans=max(ans,num);
			}
			printf("%d\n",ans);
		}	
	} 
	return 0;
}

师父的:

#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
using namespace std;
#define CLR(a,b) memset(a,b,sizeof(a))
int f[10000010];
int ant[10000010];
int find(int x)
{
	if(x!=f[x])
		f[x]=find(f[x]);
	return f[x];
}
void join(int x,int y)
{
	int fx,fy;
	fx=find(x);
	fy=find(y);
	if(fx!=fy)
		f[fx]=fy;
}
int main()
{
	int n;
	while(~scanf("%d",&n))
	{
		if(n==0)
			printf("1\n");
		else
		{
			for(int i=1;i<=10000010;i++)
				f[i]=i;	
			int a,b,maxx=0;
			for(int i=1;i<=n;i++) 
			{
				scanf("%d %d",&a,&b);
				join(a,b);
				if(maxx<max(a,b))
					maxx=max(a,b);
			}
			int num,ans=0;
//			for(int i=1;i<=maxx;i++)
//			{
//				num=0;	
//				if(f[i]==i)
//				{
//					for(int j=1;j<=maxx;j++)
//					{
//						if(i==find(f[j]))
//							num++;
//					}
//				}					
//				ans=max(ans,num);
//			}
			CLR(ant,0);
			for (int i = 1 ; i <= maxx ; i++)
			{
				ant[find(f[i])]++;
				ans = max (ans , ant[find(f[i])]);
			}
			printf("%d\n",ans);
		}	
	} 
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值