【POJ】-2377-Bad Cowtractors(最小生成树)

Bad Cowtractors
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 13532 Accepted: 5593

Description

Bessie has been hired to build a cheap internet network among Farmer John's N (2 <= N <= 1,000) barns that are conveniently numbered 1..N. FJ has already done some surveying, and found M (1 <= M <= 20,000) possible connection routes between pairs of barns. Each possible connection route has an associated cost C (1 <= C <= 100,000). Farmer John wants to spend the least amount on connecting the network; he doesn't even want to pay Bessie. 

Realizing Farmer John will not pay her, Bessie decides to do the worst job possible. She must decide on a set of connections to install so that (i) the total cost of these connections is as large as possible, (ii) all the barns are connected together (so that it is possible to reach any barn from any other barn via a path of installed connections), and (iii) so that there are no cycles among the connections (which Farmer John would easily be able to detect). Conditions (ii) and (iii) ensure that the final set of connections will look like a "tree".

Input

* Line 1: Two space-separated integers: N and M 

* Lines 2..M+1: Each line contains three space-separated integers A, B, and C that describe a connection route between barns A and B of cost C.

Output

* Line 1: A single integer, containing the price of the most expensive tree connecting all the barns. If it is not possible to connect all the barns, output -1.

Sample Input

5 8
1 2 3
1 3 7
2 3 10
2 4 4
2 5 8
3 4 6
3 5 2
4 5 17

Sample Output

42

Hint

OUTPUT DETAILS: 

The most expensive tree has cost 17 + 8 + 10 + 7 = 42. It uses the following connections: 4 to 5, 2 to 5, 2 to 3, and 1 to 3.
题意:求出不成环又使所有点连通的最大权值的和

题解:把每条边的权值有大到小排序,先取大的,之前没有连通加上权值。已连通不加。

#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
using namespace std;
#define CLR(a,b) memset(a,b,sizeof(a))
int f[1010]; 
struct node
{
	int from,to,va;
}a[20010];
bool cmp(node x,node y)
{
	return x.va>y.va;				//价值由高到低排序 
}
int find(int x)
{
	if(x!=f[x])
		f[x]=find(f[x]); 
	return f[x];	
}
bool join(int x,int y)
{
	int fx=find(x);
	int fy=find(y);
	if(fx!=fy)
	{
		f[fx]=fy;
		return true;
	}
	return false;
}
int main()
{
	int n,m;
	while(~scanf("%d %d",&n,&m))
	{
		for(int i=1;i<=n;i++)
			f[i]=i;
		for(int i=1;i<=m;i++)
			scanf("%d %d %d",&a[i].from,&a[i].to,&a[i].va);
		sort(a+1,a+1+m,cmp);
		int ant=0,flag=0;
		for(int i=1;i<=m;i++)
		{
			if(join(a[i].from,a[i].to))			//之前没有连通 ant+此边的权值 
			{
				ant+=a[i].va;
				flag++;
			}
			if(flag==n-1)
				break;							//树:n 个点,一定有n-1条边;大于 n-1 就成了环,不成立 
		}
		flag=0;
		for(int i=1;i<=n;i++)
		{
			if(f[i]==i)
				flag++;
			if(flag>1)							//根节点不唯一说明没有全部连通,不行 
				break;
		}
		if(flag>1)
			printf("-1\n");
		else
			printf("%d\n",ant);
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值