Wooden Sticks
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 18552 Accepted Submission(s): 7563
Problem Description
There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to prepare processing a stick. The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows:
(a) The setup time for the first wooden stick is 1 minute.
(b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l' and weight w' if l<=l' and w<=w'. Otherwise, it will need 1 minute for setup.
You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are (4,9), (5,2), (2,1), (3,5), and (1,4), then the minimum setup time should be 2 minutes since there is a sequence of pairs (1,4), (3,5), (4,9), (2,1), (5,2).
(a) The setup time for the first wooden stick is 1 minute.
(b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l' and weight w' if l<=l' and w<=w'. Otherwise, it will need 1 minute for setup.
You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are (4,9), (5,2), (2,1), (3,5), and (1,4), then the minimum setup time should be 2 minutes since there is a sequence of pairs (1,4), (3,5), (4,9), (2,1), (5,2).
Input
The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1<=n<=5000, that represents the number of wooden sticks in the test case, and the second line contains n 2 positive integers l1, w1, l2, w2, ..., ln, wn, each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited by one or more spaces.
Output
The output should contain the minimum setup time in minutes, one per line.
Sample Input
3 5 4 9 5 2 2 1 3 5 1 4 3 2 2 1 1 2 2 3 1 3 2 2 3 1
Sample Output
2 1 3
题解:和上一道导弹的题类似。
要求后一根木棍的长度,重量都不大于前一个,这里我们反过来思考是一样的。使后一根木棍的长度,重量不小于前一根木棍,就想题目描述中的样例那样
if you have five sticks whose pairs of length and weight are (4,9), (5,2), (2,1), (3,5), and (1,4), then the minimum setup time should be 2 minutes since there is a sequence of pairs(1,4), (3,5), (4,9),(2,1), (5,2).
先对其长度从小到大排序,这样的得到的长度都是递增的。这里要注意:长度相同时重量从小到大排序,就在这里wa了一次=.=
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
#define CLR(a,b) memset(a,b,sizeof(a))
struct node
{
int l,w;
}a[5050];
bool cmp(node x,node y)
{
if(x.l!=y.l)
return x.l<y.l;
else
return x.w<y.w; //注意这里,长度相同的时候按重量从低到高排序
}
int main()
{
int u;
scanf("%d",&u);
int dp[5050];
while(u--)
{
CLR(dp,0);
int n;
scanf("%d",&n);
for(int i=1;i<=n;i++)
scanf("%d %d",&a[i].l,&a[i].w);
sort(a+1,a+1+n,cmp); //长度排序
int num=1;
dp[num]=a[1].w; //初始是a[1].w
for(int i=2;i<=n;i++)
{
int flag=1;
for(int j=1;j<=num;j++)
{
if(a[i].w>=dp[j]) //已知后面长度不短于前面,要求后面重量不轻于前面即可
{
dp[j]=a[i].w;
flag=0;
break;
}
}
if(flag)
{
num++;
dp[num]=a[i].w;
}
}
printf("%d\n",num);
}
return 0;
}