The Worm Turns

The Worm Turns
Time Limit:2000MS     Memory Limit:65536KB     64bit IO Format:%lld & %llu

Description

Worm is an old computer game. There are many versions, but all involve maneuvering a "worm" around the screen, trying to avoid running the worm into itself or an obstacle.

We'll simulate a very simplified version here. The game will be played on a 50 x 50 board, numbered so that the square at the upper left is numbered (1, 1). The worm is initially a string of 20 connected squares. Connected squares are adjacent horizontally or vertically. The worm starts stretched out horizontally in positions (25, 11) through (25, 30), with the head of the worm at (25, 30). The worm can move either East (E), West (W), North (N) or South (S), but will never move back on itself. So, in the initial position, a W move is not possible. Thus the only two squares occupied by the worm that change in any move are its head and tail. Note that the head of the worm can move to the square just vacated by the worm's tail.

You will be given a series of moves and will simulate the moves until either the worm runs into itself, the worm runs off the board, or the worm successfully negotiates its list of moves. In the first two cases you should ignore the remaining moves in the list.

Input

There will be multiple problems instances. The input for each problem instance will be on two lines. The first line is an integer n (<100) indicating the number of moves to follow. (A value of n = 0 indicates end of input.) The next line contains n characters (either E, W, N or S), with no spaces separating the letters, indicating the sequence of moves.

Output

Generate one line of output for each problem instance. The output line should be one of the follow three:

The worm ran into itself on move m.
The worm ran off the board on move m.
The worm successfully made all m moves.

Where m is for you to determine and the first move is move 1.

Sample Input

18
NWWWWWWWWWWSESSSWS
20
SSSWWNENNNNNWWWWSSSS
30
EEEEEEEEEEEEEEEEEEEEEEEEEEEEEE
13
SWWWWWWWWWNEE
0

Sample Output

The worm successfully made all 18 moves.
The worm ran into itself on move 9.
The worm ran off the board on move 21.
The worm successfully made all 13 moves.


先贴代码,有时间再写思路

#include<iostream>
#include<cstdio>
#include<string>
#include<cstring>
using namespace std;
int n,map[51][51],step,body[21][2];
int end = 0;

int judge(int n,int m)
{
	if(m==0)
	{
		if(n > 0)
		{
			if(body[(end+19)%20][0]-1<1) return 0;
			if(map[body[(end+19)%20][0] - 1][body[(end+19)%20][1]]==1) return -1;
		} 
		else 
		{
			if(body[(end+19)%20][0]+1>50) return 0;
			if(map[body[(end+19)%20][0]+1][body[(end+19)%20][1]]==1) return -1;
		}
	}
	else 
	{
		if(m > 0)
		{
			if(body[(end+19)%20][1] - 1<1) return 0;
			if(map[body[(end+19)%20][0]][body[(end+19)%20][1]-1]==1) return -1;
		}
		else 
		{
			if(body[(end+19)%20][1]+1>50) return 0;
			if(map[body[(end+19)%20][0]][body[(end+19)%20][1]+1]==1) return -1; 
		 } 
	}
	return 1;
}

int go(string s)
{
	for(int i=0;i<20;i++) 
	{
		body[i][0] = 25;
		body[i][1] = i+11;
		//cout<<body[i][0] << " "<<body[i][1]<<endl;
	}

	for(int i=0;i<n;i++)
	{
		if(s[i]=='N') 
		{
			map[body[end][0]][body[end][1]] = 0;
			if(judge(1,0)>0)
			{
				int start = (end+19)%20;
				
				map[body[start][0]-1][body[start][1]] = 1;
				body[end][0] = body[start][0] - 1;
				body[end][1] = body[start][1];
				end = (end+1)%20;
				step++;
			}
			else return judge(1,0);
		}
		else if(s[i] == 'S')
		{
			map[body[end][0]][body[end][1]] = 0;
			if(judge(-1,0)>0)
			{
				int start = (end+19)%20;
				
				map[body[start][0]+1][body[start][1]] = 1;
				body[end][0] = body[start][0]+1;
				body[end][1] = body[start][1];
				end = (end+1)%20;
				step++;
			}
			else return judge(-1,0);
		}
		else if(s[i] == 'W')
		{
			map[body[end][0]][body[end][1]] = 0;
			if(judge(0,1)>0)
			{
				int start = (end+19)%20;
				
				map[body[start][0]][body[start][1] - 1] = 1;
				body[end][0] = body[start][0];
				body[end][1] = body[start][1] - 1;
				end = (end+1)%20;
				step++;
			}
			else return judge(0,1);
		}
		else if(s[i] == 'E')
		{
			map[body[end][0]][body[end][1]] = 0;
			if(judge(0,-1)>0)
			{
				int start = (end+19)%20;
				
				map[body[start][0]][body[start][1]+1] = 1;
				body[end][0] = body[start][0];
				body[end][1] = body[start][1] + 1;
				end = (end+1)%20;
				step++;
			}
			else return judge(0,-1);
		}
	}
	return 1;
}

int main()
{
	string s;
	while(cin >> n,n)
	{
		cin >> s; 
		step = 0;
		end = 0;
		memset(map,0,sizeof(map));
		for(int i=11;i<=30;i++)
			map[25][i] = 1;
		int ans = go(s);
		if(ans>0) printf("The worm successfully made all %d moves.\n",n);
		else if(ans<0) printf("The worm ran into itself on move %d.\n",step+1);
		else printf("The worm ran off the board on move %d.\n",step+1);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

鳄鱼儿

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值