As Easy As A+B

As Easy As A+B

These days, I am thinking about a question, how can I get a problem as easy as A+B? It is fairly difficulty to do such a thing. Of course, I got it after many waking nights.
Give you some integers, your task is to sort these number ascending (升序).
You should know how easy the problem is now!
Good luck! —-
Input
Input contains multiple test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow. Each test case contains an integer N (1<=N<=1000 the number of integers to be sorted) and then N integers follow in the same line.
It is guarantied that all integers are in the range of 32-int.
Output
For each case, print the sorting result, and one line one case.
Sample Input
2
3 2 1 3
9 1 4 7 2 5 8 3 6 9
Sample Output
1 2 3
1 2 3 4 5 6 7 8 9
AC代码

#include<stdio.h>
void main()
{
    int t;
    int a[1000];
    scanf("%d", &t);
    while (t--)
    {
        int m;
        scanf("%d", &m);
        for (int i = 0;i < m;i++)
            scanf("%d", &a[i]);
        for(int i=0;i<m;i++)
            for (int j = i;j < m;j++)
            {
                int tem;
                if (a[i] > a[j])
                {
                    tem = a[i];
                    a[i] = a[j];
                    a[j] = tem;
                }
            }
        printf("%d", a[0]);
        for (int i = 1;i < m;i++)
            printf(" %d", a[i]);
        printf("\n");

    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
EasyDarwin和ffmpeg是两个不同的工具,可以一起使用来实现流媒体的推送和播放功能。 EasyDarwin是一个流媒体服务器,可以用于搭建自己的流媒体平台。它提供了RTSP、RTMP、HLS等多种协议的支持,可以实现视频的推送、录制、转码和播放等功能。你可以通过官网下载适合你服务器的版本进行安装和配置。 ffmpeg是一个强大的多媒体处理工具,可以用于音视频的转码、剪辑、拼接、推流等操作。你可以使用ffmpeg将本地的视频文件推送到EasyDarwin流媒体服务器,然后通过HTML进行拉流播放。具体的操作步骤可以参考官方文档或者参考引用\[1\]中的命令示例。 总结起来,EasyDarwin和ffmpeg可以一起使用来实现流媒体的推送和播放功能。EasyDarwin作为流媒体服务器,提供了多种协议的支持,而ffmpeg则是一个多媒体处理工具,可以用于对音视频进行处理和推送。 #### 引用[.reference_title] - *1* [EasyDarwin+ffmpeg进行PC(摄像头+麦克风)流媒体直播服务](https://blog.csdn.net/weixin_30455365/article/details/97686191)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v91^koosearch_v1,239^v3^insert_chatgpt"}} ] [.reference_item] - *2* *3* [使用EasyDarwin+FFmpeg实现rtsp推流](https://blog.csdn.net/weixin_42547619/article/details/125071444)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v91^koosearch_v1,239^v3^insert_chatgpt"}} ] [.reference_item] [ .reference_list ]

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值