原文链接:hdu-1863-畅通工程
原文:
畅通工程
Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 33160 Accepted Submission(s): 14653
Problem Description
省政府“畅通工程”的目标是使全省任何两个村庄间都可以实现公路交通(但不一定有直接的公路相连,只要能间接通过公路可达即可)。经过调查评估,得到的统计表中列出了有可能建设公路的若干条道路的成本。现请你编写程序,计算出全省畅通需要的最低成本。
Input
测试输入包含若干测试用例。每个测试用例的第1行给出评估的道路条数 N、村庄数目M ( < 100 );随后的 N
行对应村庄间道路的成本,每行给出一对正整数,分别是两个村庄的编号,以及此两村庄间道路的成本(也是正整数)。为简单起见,村庄从1到M编号。当N为0时,全部输入结束,相应的结果不要输出。
Output
对每个测试用例,在1行里输出全省畅通需要的最低成本。若统计数据不足以保证畅通,则输出“?”。
Sample Input
3 3
1 2 1
1 3 2
2 3 4
1 3
2 3 2
0 100
Sample Output
3
?
试题分析:典型的最小生成树例题,利用克鲁斯卡尔算法既可以得出问题的解。在文中使用并查集判断加入一条边后是否会产生循环
AC代码:
//hdu1863 畅通工程 克鲁斯卡尔算法
#include<iostream>
#include<algorithm>
using namespace std;
const int maxn=10000;
int n,m;
int father[maxn];
struct edge
{
int s,e,v;
}arr[maxn];
bool cmp(edge e1,edge e2)
{
return e1.v<e2.v;
}
void f(int q)//初始化并查集
{
for(int i=1;i<=q;i++)
father[i]=i;
}
int find(int x)
{
return father[x]==x ? x : find(father[x]);
}
void com(int a,int b)//合并函数
{
int temp1=find(a);
int temp2=find(b);
if(temp1!=temp2)
father[temp1]=temp2;
}
int kruskal()
{
edge t;
int i,ans=0;
sort(arr,arr+n,cmp);
f(m);
for(i=0;i<n;i++)
{
t=arr[i];
if(find(t.s)!=find(t.e))
{
com(t.s,t.e);
ans+=t.v;
}
}
return ans;
}
int main()
{
int res,i;
bool b;
while(scanf("%d %d",&n,&m)!=EOF&&n)
{
for(i=0;i<n;i++)
cin>>arr[i].s>>arr[i].e>>arr[i].v;
res=kruskal();
b=true;
for(i=2;i<=m;i++)
{
if(find(1)!=find(i))
{
b=false;
break;
}
}
if(b)
{
cout<<res<<endl;
}
else
{
cout<<"?"<<endl;
}
}
return 0;
}