HDU 1724: Ellipse simpson积分

Ellipse

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2546    Accepted Submission(s): 1146


Problem Description
Math is important!! Many students failed in 2+2’s mathematical test, so let's AC this problem to mourn for our lost youth..
Look this sample picture:



A ellipses in the plane and center in point O. the L,R lines will be vertical through the X-axis. The problem is calculating the blue intersection area. But calculating the intersection area is dull, so I have turn to you, a talent of programmer. Your task is tell me the result of calculations.(defined PI=3.14159265 , The area of an ellipse A=PI*a*b )
 

Input
Input may contain multiple test cases. The first line is a positive integer N, denoting the number of test cases below. One case One line. The line will consist of a pair of integers a and b, denoting the ellipse equation , A pair of integers l and r, mean the L is (l, 0) and R is (r, 0). (-a <= l <= r <= a).
 

Output
For each case, output one line containing a float, the area of the intersection, accurate to three decimals after the decimal point.
 

Sample Input
 
 
2 2 1 -2 2 2 1 0 2
 

Sample Output
 
 
6.283 3.142
 

Author
威士忌


这是一道裸题

一直调了半个小时

为什么呢 精度小了 1e-10 才过 泪


#include<cmath>
#include<ctime>
#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<iostream>
#include<algorithm>
#include<iomanip>
#include<vector>
#include<string>
#include<bitset>
#include<queue>
#include<map>
#include<set>
using namespace std;

typedef double db;
typedef long long ll;

inline int read()
{
    int x=0,f=1;char ch=getchar();
    while(ch<'0'||ch>'9'){if(ch=='-')f=-1;ch=getchar();}
    while(ch>='0'&&ch<='9'){x=x*10+ch-'0';ch=getchar();}
    return x*f;
}
void print(int x)
{if(x<0)putchar('-'),x=-x;if(x>=10)print(x/10);putchar(x%10+'0');}

const db eps=1e-10;

db a,b;

db f(db x)
{return b*sqrt(1-x*x/(a*a));}

db cal(db l,db r)
{return (r-l)*(f(l)+f(r)+4*f((l+r)/2))/6;}

db simpson(db l,db r)
{
	db mid=(l+r)/2;
	db S0=cal(l,r),S1=cal(l,mid),S2=cal(mid,r);
	if(abs(S0-S1-S2)<eps) return S0;
	return simpson(l,mid)+simpson(mid,r);
}

int main()
{
	register int n=read();
	db l,r;
	while(n--)
	{
		scanf("%lf%lf%lf%lf",&a,&b,&l,&r);
		printf("%.3lf\n",simpson(l,r)*2);
	}	
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值