Eclipse中建多层级包时出现的问题

最近一直在学习idea的使用,好久没有用Eclipse了,今天想试着写一个功能,但是在Eclipse中创建包时出现问题了。创建的包都成为平级了。那么Eclipse中如何创建多层包呢?


解决方案:

    方法一:

         1)先在src文件夹下创建com包,在com包里面创建一个类,例如:




点击Finish就会出现如下:


    2)以此类推建想要建的包,在删除之前的Test类即可。以下是我的效果图。


方法二:

    1)先在src文件夹下建名为com包,如下:


 2)鼠标点击com的上一级包(这里就是src文件夹),然后新建包为com.dao包。这里会出现


不用着急,因为你只有一个包。再继续点击com的上一级包(这里就是src文件夹),然后新建com.pojo就会出现如下所示。然后就这样建包,就不会出现上面的问题了。



阅读更多
想对作者说点什么? 我来说一句

没有更多推荐了,返回首页