最长上升子序列 POJ2533

题目:

A numeric sequence of ai is ordered if a1 < a2 < ... < aN. Let the subsequence of the given numeric sequence ( a1a2, ..., aN) be any sequence ( ai1ai2, ..., aiK), where 1 <= i1 < i2 < ... < iK <= N. For example, sequence (1, 7, 3, 5, 9, 4, 8) has ordered subsequences, e. g., (1, 7), (3, 4, 8) and many others. All longest ordered subsequences are of length 4, e. g., (1, 3, 5, 8). 

Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.

输入:

The first line of input file contains the length of sequence N. The second line contains the elements of sequence - N integers in the range from 0 to 10000 each, separated by spaces. 1 <= N <= 1000

输出:

Output file must contain a single integer - the length of the longest ordered subsequence of the given sequence.

样例输入:

7
1 7 3 5 9 4 8

样例输出:

4

经典的动态规划题目,在一个序列中找到最长的递增子序列,样例输入中最长的子序列为1 3 5 9或者1 3 4 8或者1 3 5 8,长度为4。这里注意子序列与子串不同,子串是连续的,子序列可以不连续。

解法一:动态规划,时间复杂度O(n^2).

#include <iostream>
#include <algorithm>

using namespace std;

int main()
{
    int a[10000],n,b[10000],m;
    cin>>n;
    for(int i=0;i<n;i++)
        cin>>a[i];
    m=0;
    for(int i=0;i<n;i++)
    {
        b[i]=1;       //b[i]表示下标i位置处的最长上升子序列长度,初始时只有自身一个元素,所以为1
        for(int j=0;j<i;j++)
        {
            if(a[i]>a[j])         //如果当前i位置的元素大于j位置的元素,
                b[i]=max(b[i],b[j]+1);  //则在b[j]的长度上加1,为当前i位置的最长上升子序列长度
        }
    }
    for(int i=0;i<n;i++)
    {
        m=max(m,b[i]);
    }
    cout<<m<<"\n";
    return 0;
}

解法二:二分法,时间复杂度O(nlogn).

#include <cstdio>
#include <algorithm>
using namespace std;

int a[10010];
int b[10010];
int main()
{
    int n,j;
    int k=1;
    scanf("%d",&n);
    for(int i=1; i<=n; i++)
    {
        scanf("%d",&a[i]);
    }
    b[1]=a[1];
    for(int i=2; i<=n; i++)
    {
        if(a[i]>b[k])
        {
            b[++k]=a[i];
        }
        else
        {
            j=lower_bound(b+1,b+k+1,a[i])-b;
            b[j]=a[i];
        }
    }
    printf("%d",k);
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值