数据结构实验之查找一:二叉排序树

think:
1 判断两个二叉搜索树是否相同的函数中注意判断二叉搜索树rt1和二叉搜索树rt2是否为空

sdut原题链接

数据结构实验之查找一:二叉排序树
Time Limit: 400MS Memory Limit: 65536KB

Problem Description
对应给定的一个序列可以唯一确定一棵二叉排序树。然而,一棵给定的二叉排序树却可以由多种不同的序列得到。例如分别按照序列{3,1,4}和{3,4,1}插入初始为空的二叉排序树,都得到一样的结果。你的任务书对于输入的各种序列,判断它们是否能生成一样的二叉排序树。

Input
输入包含若干组测试数据。每组数据的第1行给出两个正整数N (n < = 10)和L,分别是输入序列的元素个数和需要比较的序列个数。第2行给出N个以空格分隔的正整数,作为初始插入序列生成一颗二叉排序树。随后L行,每行给出N个元素,属于L个需要检查的序列。
简单起见,我们保证每个插入序列都是1到N的一个排列。当读到N为0时,标志输入结束,这组数据不要处理。

Output
对每一组需要检查的序列,如果其生成的二叉排序树跟初始序列生成的二叉排序树一样,则输出”Yes”,否则输出”No”。

Example Input
4 2
3 1 4 2
3 4 1 2
3 2 4 1
2 1
2 1
1 2
0

Example Output
Yes
No
No

Hint

Author
xam

以下为accepted代码

#include <stdio.h>
#include <string.h>
#include <stdlib.h>
typedef struct node
{
    int date;
    struct node *left;
    struct node *right;
}BinTree;
BinTree *root = NULL;
int flag;
BinTree * Insert(BinTree *rt, int x)//二叉搜索树的插入算法
{
    if(!rt){/* 若原树为空,生成并返回一个结点的二叉搜索树*/
        rt = (BinTree *)malloc(sizeof(BinTree));
        rt->date = x;
        rt->left = rt->right = NULL;
    }
    else/* 开始找要插入元素的位置*/
    {
        if(x < rt->date)
        {
            rt->left = Insert(rt->left, x);//递归插入左子树
        }
        else if(x > rt->date)
        {
            rt->right = Insert(rt->right, x);//递归插入右子树
        }
    }
    return rt;
}
void judge(BinTree *rt1, BinTree *rt2)//判断两个二叉搜索树是否相同
{
    if(rt1 == NULL || rt2 == NULL)///判断二叉搜索树rt1和二叉搜索树rt2是否为空
        return;
    if(rt1 && rt2)
    {
        if(rt1->date != rt2->date)
            return;
        else
        {
            flag++;
            judge(rt1->left, rt2->left);
            judge(rt1->right, rt2->right);
        }
    }
}
int main()
{
    int n, m, i, x;
    while(scanf("%d", &n) != EOF && n)
    {
        scanf("%d", &m);
        for(i = 0; i < n; i++)
        {
            scanf("%d", &x);
            root = Insert(root, x);//调用二叉搜索树的插入算法
        }
        while(m--)
        {
            BinTree *root1 = NULL;
            for(i = 0; i < n; i++)
            {
                scanf("%d", &x);
                root1 = Insert(root1, x);//调用二叉搜索树的插入算法
            }
            flag = 0;///初始化
            judge(root, root1);
            if(flag == n)
                printf("Yes\n");
            else
                printf("No\n");
        }
    }
    return 0;
}


/***************************************************
User name: jk160630
Result: Accepted
Take time: 0ms
Take Memory: 104KB
Submit time: 2017-02-08 14:50:32
****************************************************/
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值