SDUT专题整理——顺序表

这篇博客详细介绍了顺序表的相关应用,包括使用移位算法删除多余元素以构建纯表,原表空间上建新表删除元素,元素位置互换的移位和逆置算法,有序顺序表的归并和查询,以及最大子段和的分治递归法和动态规划法。通过实例和代码展示了各种操作的具体实现。
摘要由CSDN通过智能技术生成

顺序表应用1:多余元素删除之移位算法
Time Limit: 1000MS Memory Limit: 650KB

Problem Description
一个长度不超过10000数据的顺序表,可能存在着一些值相同的“多余”数据元素(类型为整型),编写一个程序将“多余”的数据元素从顺序表中删除,使该表由一个“非纯表”(值相同的元素在表中可能有多个)变成一个“纯表”(值相同的元素在表中只保留第一个)。
要求:
1、必须先定义线性表的结构与操作函数,在主函数中借助该定义与操作函数调用实现问题功能;
2、本题的目标是熟悉顺序表的移位算法,因此题目必须要用元素的移位实现删除;

Input
第一行输入整数n,代表下面有n行输入;
之后输入n行,每行先输入整数m,之后输入m个数据,代表对应顺序表的每个元素。

Output
输出有n行,为每个顺序表删除多余元素后的结果

Example Input
4
5 6 9 6 8 9
3 5 5 5
5 9 8 7 6 5
10 1 2 3 4 5 5 4 2 1 3

Example Output
6 9 8
5
9 8 7 6 5
1 2 3 4 5

Hint

Author

以下为Accepted代码1——结构体

#include <iostream>

using namespace std;

struct Table{
    int size;
    int *num;
};

void Build(Table &a, int n);/*建表*/
void move_num(Table &a);/*移位算法删除重复元素*/
void pri_num(Table &a);/*输出删除重复元素之后的序列*/

int main(){
    int T, n;
    Table a;/*定义表a*/
    cin >> T;
    while(T--){
        cin >> n;
        Build(a, n);
        move_num(a);
        pri_num(a);
    }
    return 0;
}
void Build(Table &a, int n){
    a.size = n;
    a.num = new int[11400];
    for(int i = 0; i < n; i++)
        cin >> a.num[i];
}
void move_num(Table &a){
    for(int i = 0; i < a.size; i++){
        int j = i + 1;
        while(j < a.size){
            if(a.num[i] != a.num[j])
                j++;
            else {
                for(int k = j; k < a.size-1; k++)
                    a.num[k] = a.num[k+1];
                a.size--;
            }
        }
    }
}
void pri_num(Table &a){
    for(int i = 0; i < a.size; i++){
        cout << a.num[i];
        i == a.size-1? cout << '\n': cout << ' ';
    }
    delete []a.num;
}


/***************************************************
User name: 
Result: Accepted
Take time: 44ms
Take Memory: 244KB
Submit time: 2017-09-15 16:53:15
****************************************************/

以下为Accepted代码2——C++类

#include <iostream>

using namespace std;

class Table{
private:
    int size;
    int *num;
public:
    void build_table(int n);
    void move_num();
    void pri_num();
    void delete_memory();
};

void Table::build_table(int n){
    size = n;
    num = new int[n+4];
    for(int i = 0; i < n; i++)
        cin >> num[i];
}
void Table::move_num(){
    for(int i = 0; i < size; i++){
        int j = i + 1;
        while(j < size){
            if(num[i] != num[j])
                j++;
            else {
                for(int k = j; k < size-1; k++)
                    num[k] = num[k+1];
                size--;
            }
        }
    }
}
void Table::pri_num(){
    for(int i = 0; i < size; i++){
        cout << num[i];
        i == size-1? cout << '\n': cout << ' ';
    }
}
void Table::delete_memory(){
    delete []num;
}

int main(){
    int T, n;
    Table test;
    cin >> T;
    while(T--){
        cin >> n;
        test.build_table(n);
        test.move_num();
        test.pri_num();
        test.delete_memory();
    }
    return 0;
}


/***************************************************
User name: 
Result: Accepted
Take time: 44ms
Take Memory: 244KB
Submit time: 2017-09-15 17:06:33
****************************************************/

顺序表应用2:多余元素删除之建表算法
Time Limit: 3MS Memory Limit: 600KB

Problem Description
一个长度不超过10000数据的顺序表,可能存在着一些值相同的“多余”数据元素(类型为整型),编写一个程序将“多余”的数据元素从顺序表中删除,使该表由一个“非纯表”(值相同的元素在表中可能有多个)变成一个“纯表”(值相同的元素在表中只保留第一个)。
要求:
1、必须先定义线性表的结构与操作函数,在主函数中借助该定义与操作函数调用实现问题功能;
2、本题的目标是熟悉在顺序表原表空间基础上建新表的算法,要在原顺序表空间的基础上完成完成删除,建表过程不得开辟新的表空间;
3、不得采用原表元素移位删除的方式。

<
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值