Stall Reservations - POJ3190 贪心

Stall Reservations
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 3541 Accepted: 1266 Special Judge

Description

Oh those picky N (1 <= N <= 50,000) cows! They are so picky that each one will only be milked over some precise time interval A..B (1 <= A <= B <= 1,000,000), which includes both times A and B. Obviously, FJ must create a reservation system to determine which stall each cow can be assigned for her milking time. Of course, no cow will share such a private moment with other cows. 

Help FJ by determining:
  • The minimum number of stalls required in the barn so that each cow can have her private milking period
  • An assignment of cows to these stalls over time
Many answers are correct for each test dataset; a program will grade your answer.

Input

Line 1: A single integer, N 

Lines 2..N+1: Line i+1 describes cow i's milking interval with two space-separated integers.

Output

Line 1: The minimum number of stalls the barn must have. 

Lines 2..N+1: Line i+1 describes the stall to which cow i will be assigned for her milking period.

Sample Input

5
1 10
2 4
3 6
5 8
4 7

Sample Output

4
1
2
3
2
4

Hint

Explanation of the sample: 

Here's a graphical schedule for this output: 

Time     1  2  3  4  5  6  7  8  9 10

Stall 1 c1>>>>>>>>>>>>>>>>>>>>>>>>>>>

Stall 2 .. c2>>>>>> c4>>>>>>>>> .. ..

Stall 3 .. .. c3>>>>>>>>> .. .. .. ..

Stall 4 .. .. .. c5>>>>>>>>> .. .. ..
Other outputs using the same number of stalls are possible.

题意:每个牛有一个特定的产奶时间,如果两个牛的产奶时间冲突的话就要新加一个牛棚,问最少需要多少个牛棚让每头牛都能产奶并且不互相冲突,输出最小数目及每头牛所在的牛棚编号


思路:由于每头牛的产奶时间是固定的,所以对其排序后再遍历时只需看结束时间最早的那个牛棚能否允许当前的牛前去产奶,能的话更新牛棚的结束时间,不能的话申请新的牛棚,利用优先队列维护牛棚


#include<iostream>
#include<cstdio>
#include<algorithm>
#include<queue>
#define MAXN 50100
using namespace std;
struct node
{
	int s,e;
	int num,id;
}cow[MAXN];
bool cmp(node a,node b)
{
	return a.s<b.s;
}
bool cmp1(node a,node b)
{
	return a.num<b.num;
}
struct stall
{
	int T,ID;
	stall(int t,int n){
		T=t;ID=n;
	}
	bool operator< (const stall &b) const {
		return T>b.T;
	}
};
priority_queue<stall> qq;
int main()
{
//	freopen("in.txt","r",stdin);
	int n;
	scanf("%d",&n);
	for(int i=1;i<=n;i++){
		scanf("%d%d",&cow[i].s,&cow[i].e);
		cow[i].num=i;
	}
	sort(cow+1,cow+1+n,cmp);
	for(int i=1;i<=n;i++) {
		if(!qq.empty()){
			stall temp=qq.top();
			if(cow[i].s>temp.T){
				temp.T=cow[i].e;
				cow[i].id=temp.ID;
				qq.pop();
				qq.push(temp);
			}else {
				cow[i].id=qq.size()+1;
				qq.push(stall(cow[i].e,cow[i].id));
			}
		}else{
			cow[i].id=1;
			qq.push(stall(cow[i].e,1));
		}
	}
	printf("%d\n",qq.size());
	sort(cow+1,cow+1+n,cmp1);
	for(int i=1;i<=n;i++)
		printf("%d\n",cow[i].id);
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值