音量调节
- Description
一个吉他手准备参加一场演出。他不喜欢在演出时始终使用同一个音量,所以他决定每一首歌之前他都要改变一次音量。在演出开始之前,他已经做好了一个列表,里面写着在每首歌开始之前他想要改变的音量是多少。每一次改变音量,他可以选择调高也可以调低。
音量用一个整数描述。输入文件中给定整数beginLevel,代表吉他刚开始的音量,以及整数maxLevel,代表吉他的最大音量。音量不能小于0也不能大于maxLevel。输入文件中还给定了n个整数 ,表示在第i首歌开始之前吉他手想要改变的音量是多少。
吉他手想以最大的音量演奏最后一首歌,你的任务是找到这个最大音量是多少。
- Input Format
第一行依次为三个整数:n, beginLevel, maxlevel。
第二行依次为n个整数: C1,C2,C3……Cn。
- Output Format
输出演奏最后一首歌的最大音量。如果吉他手无法避免音量低于0或者高于maxLevel,输出-1。
- Sample Input
3 5 10
5 3 7
- Sample Output
10
- Hint
【数据范围】
对于30%的数据 1<=n<=10
对于100%的数据 1<=n<=50 , 1<=ci<=maxlevel , 1<=maxlevel <= 1000, 0<= beginlevel <= maxlevel
- 分析
用F[i][j]记录一下第i首歌能否达到j的音量。
#include <queue>
#include <stack>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
int n,B,M,Ans=-1,c;
bool F[51][1003];
int main(){
freopen("in.txt","r",stdin);
freopen("out.txt","w",stdout);
scanf("%d%d%d",&n,&B,&M);
F[0][B]=1;
for (int i=1;i<=n;i++){
scanf("%d",&c);
for (int j=0;j<=M;j++){
if (F[i-1][j]){
if (j+c<=M) F[i][j+c]=1;
if (j-c>=0) F[i][j-c]=1;
}
}
}
for (int i=0;i<=M;i++)
if (F[n][i]) Ans=max(Ans,i);
printf("%d",Ans);
fclose(stdin); fclose(stdout);
return 0;
}