HDU1115 Lifting the Stone

Lifting the Stone

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 8088    Accepted Submission(s): 3419


Problem Description
There are many secret openings in the floor which are covered by a big heavy stone. When the stone is lifted up, a special mechanism detects this and activates poisoned arrows that are shot near the opening. The only possibility is to lift the stone very slowly and carefully. The ACM team must connect a rope to the stone and then lift it using a pulley. Moreover, the stone must be lifted all at once; no side can rise before another. So it is very important to find the centre of gravity and connect the rope exactly to that point. The stone has a polygonal shape and its height is the same throughout the whole polygonal area. Your task is to find the centre of gravity for the given polygon. 
 

Input
The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing a single integer N (3 <= N <= 1000000) indicating the number of points that form the polygon. This is followed by N lines, each containing two integers Xi and Yi (|Xi|, |Yi| <= 20000). These numbers are the coordinates of the i-th point. When we connect the points in the given order, we get a polygon. You may assume that the edges never touch each other (except the neighboring ones) and that they never cross. The area of the polygon is never zero, i.e. it cannot collapse into a single line. 
 

Output
Print exactly one line for each test case. The line should contain exactly two numbers separated by one space. These numbers are the coordinates of the centre of gravity. Round the coordinates to the nearest number with exactly two digits after the decimal point (0.005 rounds up to 0.01). Note that the centre of gravity may be outside the polygon, if its shape is not convex. If there is such a case in the input data, print the centre anyway. 
 

Sample Input
  
  
2 4 5 0 0 5 -5 0 0 -5 4 1 1 11 1 11 11 1 11
 

Sample Output
  
  
0.00 0.00 6.00 6.00
        一道计算几何的题目,要求你计算出石头的重心。
     先给大家补充三角形的面积公式,S = ((x2-x1)*(y3-y1)-(x3-x1)*(y2-y1))/2,这是个叉积运算,有正有负。
     ①质量集中在顶点上。n个顶点坐标为(xi,yi),质量为mi,则重心
  X = ∑( xi×mi ) / ∑mi
  Y = ∑( yi×mi ) / ∑mi
  特殊地,若每个点的质量相同,则
  X = ∑xi / n
  Y = ∑yi / n
     ②质量分布均匀,一个特例,质量均匀的三角形重心:
  X = ( x0 + x1 + x2 ) / 3
  Y = ( y0 + y1 + y2 ) / 3
      求任意多边形的重心,此题质量分布均匀,所以将图形划分成n-2个小三角形,然后求每个小三角形的重心和面积,转换成①的方法。我们也可以原点为依据划分成n+1个小三角形,进行每个小 三角形的重心计算和面积计算从而转换成①的方法。
      如果原点在这个凸多边形之内求出来的面积和正好是凸多边形的面积,如果在凸多边形范围之外,我们求出来的面积和也等于凸多边形的面积(三角形三条边构成的回路是逆时针的话S为正,顺时针为负,但在计算的时候不用考虑输入顺序的逆时针顺时针,相除后就抵消了)。我用的是第二种方法,以原点作为依据分割凸多边形。

#include <iostream>
#include <cstdio>
using namespace std;
int t,n;
struct node{
  double x,y;
  }p[1000003];
int main()
{
    scanf("%d",&t);
    while(t--){
       scanf("%d",&n);
       for(int i = 0;i < n;i++){
         scanf("%lf%lf",&p[i].x,&p[i].y);
         }
       double A = 0,tempx = 0,tempy = 0;
       for(int i = 0;i < n-1;i++){
            tempx += (p[i].x + p[i+1].x)*(p[i].x*p[i+1].y-p[i+1].x*p[i].y);
            tempy += (p[i].y + p[i+1].y)*(p[i].x*p[i+1].y-p[i+1].x*p[i].y);
            A += (p[i].x*p[i+1].y-p[i+1].x*p[i].y)/2;
            //printf("%.2f ",p[i].x + p[i+1].x);
       }
       tempx += (p[n-1].x + p[0].x)*(p[n-1].x*p[0].y-p[0].x*p[n-1].y);
       tempy += (p[n-1].y + p[0].y)*(p[n-1].x*p[0].y-p[0].x*p[n-1].y);
       A += (p[n-1].x*p[0].y-p[0].x*p[n-1].y)/2;
       tempx /= 6*A,tempy /= 6*A;
       printf("%.2f %.2f\n",tempx,tempy);
    }
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值