Number Steps

http://acm.hdu.edu.cn/showproblem.php?pid=1391

Number Steps

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4553    Accepted Submission(s): 2773


Problem Description
Starting from point (0,0) on a plane, we have written all non-negative integers 0, 1, 2,... as shown in the figure. For example, 1, 2, and 3 has been written at points (1,1), (2,0), and (3, 1) respectively and this pattern has continued.



You are to write a program that reads the coordinates of a point (x, y), and writes the number (if any) that has been written at that point. (x, y) coordinates in the input are in the range 0...5000.
 

Input
The first line of the input is N, the number of test cases for this problem. In each of the N following lines, there is x, and y representing the coordinates (x, y) of a point.
 

Output
For each point in the input, write the number written at that point or write No Number if there is none.
 

Sample Input
  
  
3 4 2 6 6 3 4
 

Sample Output
  
  
6 12 No Number
 

Source
 

用数组的话会照成很大的浪费,答案很少,所以可以慢慢打补丁,关键是除了0外接下来每4个构成一个正方形,在上面的满足ans=x+y;

#include <cstdio>
int main()
{
    int n,x,y;
    scanf("%d",&n);
    while(n--){
        scanf("%d%d",&x,&y);
        int add=x+y;
        if(x-y>2||y>x&&add%2)printf("No Number\n");
        else {
            int p;
            if(x%2&&x==y){p=x*2+2;printf("%d\n",p-3);}
            else if(x%2&&x==y+2){p=x*2-2;printf("%d\n",p-1);}
            else if(x%2==0&&x==y)printf("%d\n",add);
            else if(x%2==0&&x==y+2){p=2*x;printf("%d\n",p-2);}
            else printf("No Number\n");
        }
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值