Tunnel Warfare(线段树)

http://acm.hust.edu.cn/vjudge/contest/view.action?cid=66989#problem/I

I - Tunnel Warfare
Time Limit:2000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

During the War of Resistance Against Japan, tunnel warfare was carried out extensively in the vast areas of north China Plain. Generally speaking, villages connected by tunnels lay in a line. Except the two at the ends, every village was directly connected with two neighboring ones. 

Frequently the invaders launched attack on some of the villages and destroyed the parts of tunnels in them. The Eighth Route Army commanders requested the latest connection state of the tunnels and villages. If some villages are severely isolated, restoration of connection must be done immediately! 
 

Input

The first line of the input contains two positive integers n and m (n, m ≤ 50,000) indicating the number of villages and events. Each of the next m lines describes an event. 

There are three different events described in different format shown below: 

D x: The x-th village was destroyed. 

Q x: The Army commands requested the number of villages that x-th village was directly or indirectly connected with including itself. 

R: The village destroyed last was rebuilt. 
 

Output

Output the answer to each of the Army commanders’ request in order on a separate line. 
 

Sample Input

       
       
7 9 D 3 D 6 D 5 Q 4 Q 5 R Q 4 R Q 4
 

Sample Output

       
       
1 0 2 4
 

#include <cstdio>
#include <algorithm>
#define SI(T)int T;scanf("%d",&T)
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
using namespace std;
const int SIZE=5e4+10;
const int maxn=500000;
int st[SIZE];
struct node{
    int sum_l,sum_r,sum;//sum_l从节点左边开始的连续多少个,sum_r一样,sum是节点最大的连续个数,其实可以不必sum,下面的关系挺清楚的
}a[SIZE<<2];
void pushup(int l,int r,int rt){
    a[rt].sum_l=a[rt<<1].sum_l;
    a[rt].sum_r=a[rt<<1|1].sum_r;
    a[rt].sum=max(max(a[rt<<1].sum,a[rt<<1|1].sum),a[rt<<1].sum_r+a[rt<<1|1].sum_l);
    int m=r-l+1;
    if(a[rt].sum_l==m-(m>>1))a[rt].sum_l+=a[rt<<1|1].sum_l;
    if(a[rt].sum_r==m>>1)a[rt].sum_r+=a[rt<<1].sum_r;
}
void build(int l,int r,int rt){
    a[rt].sum=a[rt].sum_l=a[rt].sum_r=r-l+1;
    if(l==r)return;
    int m=(l+r)>>1;
    build(lson);
    build(rson);
}
void update(int p,int c,int l,int r,int rt){
    if(l==r){
        a[rt].sum=a[rt].sum_l=a[rt].sum_r=c;
        return;
    }
    int m=(l+r)>>1;
    if(p<=m)update(p,c,lson);
    if(p>m)update(p,c,rson);
    pushup(l,r,rt);
}
int query(int p,int l,int r,int rt){
    if(l==r||a[rt].sum==0||a[rt].sum==r-l+1)return a[rt].sum;
    int m=(l+r)>>1;
    if(p<=m){
        if(m-a[rt<<1].sum_r+1<=p)return query(p,lson)+query(m+1,rson);
        return query(p,lson);
    }
    else{
        if(m+a[rt<<1|1].sum_l>=p)return query(p,rson)+query(m,lson);
        return query(p,rson);
    }
}
int main()
{
    int n,m,x;
   // freopen("F://in.txt","r",stdin);
    char s[10];
    while(scanf("%d%d",&n,&m)!=EOF){
        int t=0;
        build(1,n,1);
        while(m--){
            scanf("%s",s);
            if(s[0]=='D'){
                scanf("%d",&x);
                update(x,0,1,n,1);
                st[t++]=x;
            }
            else if(s[0]=='Q'){
                scanf("%d",&x);
                printf("%d\n",query(x,1,n,1));
            }
            else {
                x=st[--t];
                update(x,1,1,n,1);
            }
        }
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值