数字

 

                  数字

                Time Limit: 1000 ms Memory Limit: 65536 KiB

Problem Description

定义f(x) = {比x小,不可以被x整除并且不和x互质的数的个数}(x为正整数)。

当f(x) 是奇数的时候我们称x为“奇真数”。

给出两个数x,y求区间[x,y]内的“奇真数”的个数。

 

Input

 第一行输入一个数N代表测试数据个数(N<=20)。接下来N行每行两个正整数x , y ( 0 < x <= y < 2^31)。

 

Output

 对于每个测试数据输出“奇真数”的个数,每行输出一个结果。

 

Sample Input

2
1 1
1 10

Sample Output

0
4

Hint

  中国海洋大学第三届“朗讯杯”编程比赛高级组试题

package hello;
import java.util.*;
public class Main{
	public static void main(String [] args)
	{
		Scanner reader = new Scanner(System.in);
		long n = reader.nextInt();
		while(n-- > 0)
		{
			long x = reader.nextLong();
			long y = reader.nextLong();
			System.out.println(F(y) - F(x - 1));
		}
		reader.close();
	}
	public static long F(long x)
	{
		if(x <= (long)2)return 0;
		else 
		{
			return x / 2 - 1 + ((long)Math.sqrt((long)x * 1.0)  % 2 == 1 ? 0 : -1);
		}
	}
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值