问题描述:
给你一组数(未排序),请你设计一个程序:求出里面个数最多的数。并输出这个数的长度。
例如:给你的数是:1、 2、 3、 3、 4、 4、 5、 5、 5 、6, 其中只有6组数:1, 2, 3-3, 4-4, 5-5-5 and 6.
最长的是5那组,长度为3。所以输出3。
输入:
第一行为整数t((1 ≤ t ≤ 10)),表示有n组测试数据。
每组测试数据包括两行,第一行为数组的长度n (1 ≤ n ≤ 10000)。第二行为n个整数,所有整数Mi的范围都是(1 ≤ Mi < 2^32)
输出:
对应每组数据,输出个数最多的数的长度。
样例输入:
1
10
1 2 3 3 4 4 5 5 5 6
样例输出:
3
参考代码:
#include<stdio.h>
int fanc(int a[],int n,int x)
{
int count=0;
for(int j=0;j<n;j++)
{
if(a[j]==x)
count++;
}
return count;
}
int main()
{
int t,n,a[10000],max=-1,x;
scanf("%d",&t);
for(int i=0;i<t;i++)
{
scanf("%d",&n);
for(int j=0;j<n;j++)
scanf("%d", &a[j]);
for(int k=0;k<n;k++)
{
x = fanc(a, n, a[k]);
if(x>max)
max=x;
}
printf("%d\n",max);
}
return 0;
}