C++ 紫薯 6.4 图————用DFS求联通块

    6.4 图

Given a set of sticks of various lengths, is it possible to join them end-to-end to form a square?

Input
The first line of input contains N, the number of test cases. Each test case begins with an integer 4 <= M <= 20,
 the number of sticks. M integers follow; each gives the length of a stick - an integer between 1 and 10,000.
Output
For each case, output a line containing "yes" if is is possible to form a square; otherwise output "no".
Sample Input
3
4 1 1 1 1
5 10 20 30 40 50
8 1 7 2 6 4 4 3 5
Sample Output
yes
no
yes

两种方法

一,

#include <iostream>
using namespace std;
const int INF=100;
int n,m;
char mp[INF][INF];  
void view(int i,int j)         //遍历函数
{
  if(mp[i][j]!='@'||i<0||j<0||i>=n||j>=m)  //判断是否越界,是否为要求字符
    return ;
  else
  {
      mp[i][j]='*';
      view(i-1,j-1);    //  遍历mp[i][j]周围的格子
      view(i-1,j);
      view(i-1,j+1);
      view(i,j-1);
      view(i,j+1);
      view(i+1,j-1);
      view(i+1,j);
      view(i+1,j+1);
  }
}
int main()
{

    while(cin>>n>>m)
    {    int p=0;
        if(n==0||m==0)  break;   //输入0 0结束
        for(int i=0;i<n;i++)
       {for(int j=0;j<m;j++)
          cin>>mp[i][j];
       }
        for(int i=0;i<n;i++)
           { for(int j=0;j<m;j++)
              {if(mp[i][j]=='@')   
              { view(i,j);
                  p++;         //计数器,查看便利几次可以遍历所有的指定字符
                }
              }
           }
        cout<<p<<endl;
    }
}



二,紫薯上的方法

#include<iostream>
#include<cstring>
const int man=100;
int mp[man][man];
int sc[man][man];    
int m,n;
using namespace std;
void la(int i,int j,int p)
{
    if(i<0||i>=m||j<0||j>=n) return ;
    if(sc[i][j]>0||mp[i][j]!='@') return ;
    sc[i][j]=p;       //连通分量编号,即记录访问几次指定字符附近的格子
    for(int a=-1;a<=1;a++) 
    {
        for(int b=-1;b<=1;b++)
            if(a!=0||b!=0)     //除自身的格子,便利周围的
            la(a+i,b+j,p);
    }
}
int main()
{
    int p=0;
    while(cin>>m>>n)
    {
        if(m==0||n==0)
            break;
            memset(sc,0,sizeof(sc));     //将设定的数组初始化
            for(int i=0;i<m;i++)
            {
                for(int j=0;j<n;j++)
                    cin>>mp[i][j];
            }
            for(int i=0;i<m;i++)
                for(int j=0;j<n;j++)
              if(sc[i][j]==0&&mp[i][j]=='@')   //遍历条件
                        la(i,j,++p);
                    cout<<p<<endl;
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值