J - Invitation Cards

J - Invitation Cards

In the age of television, not many people attend theater performances. Antique Comedians of Malidinesia are aware of this fact. They want to propagate theater and, most of all, Antique Comedies. They have printed invitation cards with all the necessary information and with the programme. A lot of students were hired to distribute these invitations among the people. Each student volunteer has assigned exactly one bus stop and he or she stays there the whole day and gives invitation to people travelling by bus. A special course was taken where students learned how to influence people and what is the difference between influencing and robbery.
The transport system is very special: all lines are unidirectional and connect exactly two stops. Buses leave the originating stop with passangers each half an hour. After reaching the destination stop they return empty to the originating stop, where they wait until the next full half an hour, e.g. X:00 or X:30, where ‘X’ denotes the hour. The fee for transport between two stops is given by special tables and is payable on the spot. The lines are planned in such a way, that each round trip (i.e. a journey starting and finishing at the same stop) passes through a Central Checkpoint Stop (CCS) where each passenger has to pass a thorough check including body scan.
All the ACM student members leave the CCS each morning. Each volunteer is to move to one predetermined stop to invite passengers. There are as many volunteers as stops. At the end of the day, all students travel back to CCS. You are to write a computer program that helps ACM to minimize the amount of money to pay every day for the transport of their employees.

Input

The input consists of N cases. The first line of the input contains only positive integer N. Then follow the cases. Each case begins with a line containing exactly two integers P and Q, 1 <= P,Q <= 1000000. P is the number of stops including CCS and Q the number of bus lines. Then there are Q lines, each describing one bus line. Each of the lines contains exactly three numbers - the originating stop, the destination stop and the price. The CCS is designated by number 1. Prices are positive integers the sum of which is smaller than 1000000000. You can also assume it is always possible to get from any stop to any other stop.

Output

For each case, print one line containing the minimum amount of money to be paid each day by ACM for the travel costs of its volunteers.

Sample Input

2
2 2
1 2 13
2 1 33
4 6
1 2 10
2 1 60
1 3 20
3 4 10
2 4 5
4 1 50

Sample Output

46
210

题意:
就是求单向路之间的最小值,但是我用迪杰斯特拉算法超时了,所以还是要用spfa算法。

SPFA AC代码:

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <string.h>
#include <queue>
#include <map>
using namespace std;
typedef long long ll;
#define MAX 0x3f3f3f3f
const int maxn=1e6+10;
int n,m,pos;
int head[maxn],book[maxn];
ll d[maxn];
struct Node{
    int u,v,w,next;
}node[maxn];

void add(int a,int b,int c)
{
    node[pos].u=a;
    node[pos].v=b;
    node[pos].w=c;
    node[pos].next=head[a];
    head[a]=pos++;
}
ll spfa(int s)
{
    queue<int>qu;
    qu.push(s);
    book[s]=1;
    d[s]=0;
    while(!qu.empty())
    {
        int now=qu.front();
        qu.pop();
        book[now]=0;
        for(int i=head[now];i!=-1;i=node[i].next)
        {
            if(d[node[i].v]>d[now]+node[i].w)
            {
                d[node[i].v]=d[now]+node[i].w;
                if(!book[node[i].v])
                {
                    qu.push(node[i].v);
                    book[node[i].v]=1;
                }
            }
        }
    }
    ll summ=0;
    for(int i=1;i<=n;i++)
    {
        if(d[i]!=MAX)
            summ+=d[i];
    }
    return summ;
}
int main()
{
    int t;
    int a,b,c;
    scanf("%d",&t);
    while(t--)
    {

        pos=0;
        scanf("%d%d",&n,&m);
        for(int i=1;i<=n;++i)
        {
            d[i]=MAX;
            book[i]=0;
        }
        memset(head,-1,sizeof(head));

        for(int i=1;i<=m;i++)
        {
            scanf("%d%d%d",&a,&b,&c);
            add(a,b,c);
        }//正向建图
        ll result=spfa(1);
        pos=0;
        for(int i=1;i<=n;++i)
        {
            d[i]=MAX;
            book[i]=0;
        }
        memset(head,-1,sizeof(head));

        for(int i=0;i<m;i++)
        {
            a=node[i].u;
            b=node[i].v;
            c=node[i].w;
            add(b,a,c);
        }//反向建图
        ll result2=result+spfa(1);
        printf("%lld\n",result2);
    }

    return 0;
}

迪杰斯特拉超时代码:

#include<stdio.h>
#define Max 0x3fffffff
int mapp[10005][10005];//记录每两个点之间的费用
int dis[10005];
void dijkstra(int m) //主算法
{
    int visit[10005]= {0}; //先把所有的点标记为未走过
    int minn,i,j,k;
    visit[1]=1; //起点标记
    for(int i=1; i<m; i++)//一个个点来
    {
        minn=Max; //每次循环都要把minn归为最大
        k=1; //k也要归1
        for(int j=1; j<=m; j++) //选择费用最短的点,下一个for循环会用到
        {
            if(visit[j]==0&&dis[j]<minn)
            {
                minn=dis[j];
                k=j;
            }
        }

        visit[k]=1;
        for(int j=1; j<=m; j++)
        {
            if(visit[j]==0&&dis[j]>dis[k]+mapp[k][j])//比较dis[j](mapp[1][j])与刚才更新的费用最短的点到j点那个费用更短,更新值
                dis[j]=dis[k]+mapp[k][j];
        }
    }
}
int main()
{
    int N,m,n,from,to,cost;
    scanf("%d",&N);
    while(N--)
    {
        scanf("%d %d",&m,&n);
        for(int i=1; i<=m; i++)//初始化
        {
            mapp[i][i]=0;//自己到自己的费用为0
            for(int j=1; j<i; ++j) //其余各点的费用先标记为无穷大
                mapp[i][j]=mapp[j][i]=Max;//双向都要标记
        }
        for(int i=1; i<=n; i++) //输入
        {
            scanf("%d %d %d",&from,&to,&cost);
            if(mapp[from][to]>cost)//若之前已经存过该两点的费用了,那就比较这次的和上次的哪次更短,存费用更短的那次
                mapp[from][to]=cost;
        }
        int money=0;
        for(int i=1; i<=m; i++) //存从起点到每个点的费用,最后要求的就是起点到终点的费用
            dis[i]=mapp[1][i];
        dijkstra(m);
        for(int i=1; i<=m; i++)
        {
            money+=dis[i];
            printf("%d\n",dis[i]);
        }
        int temp;
        for(int i=1; i<=n; i++) //把路线反过来,求回来的最少费用
        {
            for(int j=i+1; j<=n; j++)
            {
                temp=mapp[i][j];
                mapp[i][j]=mapp[j][i];
                mapp[j][i]=temp;
            }
        }
        for(int i=1; i<=m; i++) //更新dis
            dis[i]=mapp[1][i];

        dijkstra(m);

        for(int i=1; i<=m; i++)
        {
            money+=dis[i];
            printf("%d\n",dis[i]);
        }
        printf("%d\n",money);
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值