PTA7-11 N个数求和

本题的要求很简单,就是求N个数字的和。麻烦的是,这些数字是以有理数分子/分母的形式给出的,你输出的和也必须是有理数的形式。

输入格式:

输入第一行给出一个正整数N(≤100)。随后一行按格式a1/b1 a2/b2 ...给出N个有理数。题目保证所有分子和分母都在长整型范围内。另外,负数的符号一定出现在分子前面。

输出格式:

输出上述数字和的最简形式 —— 即将结果写成整数部分 分数部分,其中分数部分写成分子/分母,要求分子小于分母,且它们没有公因子。如果结果的整数部分为0,则只输出分数部分。

输入样例1:

5
2/5 4/15 1/30 -2/60 8/3

结尾无空行

输出样例1:

3 1/3

结尾无空行

输入样例2:

2
4/3 2/3

输出样例2:

2

输入样例3:

3
1/3 -1/6 1/8

输出样例3:

7/24

#include <stdio.h>
#include <math.h>
long gcd(long a,long b)
{
    if(a==0)
      return 0;
    else
      return (b==0)?a:gcd(b,a%b);
}
int main()
{
    int n;
    long lcp;
    long a,b,c,d,t0;
    int i = 1;
    scanf("%d",&n);
    scanf("%ld/%ld",&a,&b);
    t0 = gcd(a,b);
    // reduce 
    if(a!=0)
    {
      a=a/t0;
      b=b/t0;
    }
    while(i<n)
    {
      scanf("%ld/%ld",&c,&d);
      // least common product 
      lcp = b / gcd(b,d) * d;
      a = a * lcp / b + c * lcp / d;
      b = lcp;
      t0 = gcd(a,b);
      // reduce
      if(t0!=0)
      {
        a=a/t0;
        b=b/t0;
      }
      i++;
    }
    if(a!=0 && a/b==0) // a<b, proper fraction 
    {
      printf("%ld/%ld\n",a%b,b);
    }else if(a%b==0) // no remainder
    {
      printf("%ld\n",a/b);
    }else // mixed number 
    {
      printf("%ld %ld/%ld\n",a/b,a%b,b);
    }
    return 0;
}
 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
以下是一元多项式的加法 C 语言代码: ```c #include <stdio.h> #include <stdlib.h> typedef struct node { int coef; // 系数 int exp; // 指数 struct node *next; } Node; Node *createNode(int coef, int exp) { Node *newNode = (Node *)malloc(sizeof(Node)); newNode->coef = coef; newNode->exp = exp; newNode->next = NULL; return newNode; } Node *addPoly(Node *poly1, Node *poly2) { Node *head = createNode(0, 0); Node *p = head; while (poly1 && poly2) { if (poly1->exp > poly2->exp) { p->next = createNode(poly1->coef, poly1->exp); poly1 = poly1->next; } else if (poly1->exp < poly2->exp) { p->next = createNode(poly2->coef, poly2->exp); poly2 = poly2->next; } else { int sum = poly1->coef + poly2->coef; if (sum != 0) { p->next = createNode(sum, poly1->exp); } poly1 = poly1->next; poly2 = poly2->next; } p = p->next; } p->next = poly1 ? poly1 : poly2; return head->next; } void printPoly(Node *poly) { while (poly) { printf("%dx^%d", poly->coef, poly->exp); if (poly->next && poly->next->coef > 0) { printf("+"); } poly = poly->next; } printf("\n"); } int main() { int n, coef, exp; Node *poly1 = createNode(0, 0); Node *poly2 = createNode(0, 0); scanf("%d", &n); for (int i = 0; i < n; i++) { scanf("%d%d", &coef, &exp); Node *node = createNode(coef, exp); node->next = poly1->next; poly1->next = node; } scanf("%d", &n); for (int i = 0; i < n; i++) { scanf("%d%d", &coef, &exp); Node *node = createNode(coef, exp); node->next = poly2->next; poly2->next = node; } Node *sum = addPoly(poly1->next, poly2->next); printPoly(sum); return 0; } ``` 在这个代码,我们首先定义了一个结构体 `Node` 来存储一元多项式的每一项。其,`coef` 表示系数,`exp` 表示指数,`next` 表示指向下一项的指针。 然后,我们通过 `createNode` 函数来创建一个新的节点,并将 `coef` 和 `exp` 初始化为指定的值。 接下来,我们定义了一个 `addPoly` 函数来实现多项式的加法。该函数输入两个多项式的头节点指针 `poly1` 和 `poly2`,并返回一个新的多项式的头节点指针。 在 `addPoly` 函数,我们先创建一个新的头节点 `head`,然后使用指针 `p` 指向 `head`,依次遍历 `poly1` 和 `poly2` 的每一项,将它们相加并存储在一个新的节点,将该节点插入到新多项式的尾部。最后,将剩余的多项式直接连接到新多项式的尾部。 最后,我们定义了一个 `printPoly` 函数来输出一元多项式,然后在 `main` 函数读入两个多项式,并调用 `addPoly` 函数来求和,最后输出结果。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值