Crossed Ladders(二分+几何)

<span style="font-family: Arial, Helvetica, sans-serif; background-color: rgb(255, 255, 255);">E - </span><span style="color: blue; font-family: Arial, Helvetica, sans-serif; background-color: rgb(255, 255, 255);">Crossed Ladders</span>
Time Limit:2000MS     Memory Limit:32768KB     64bit IO Format:%lld & %llu

Description

A narrow street is lined with tall buildings. An x foot long ladder is rested at the base of the building on the right side of the street and leans on the building on the left side. A y foot long ladder is rested at the base of the building on the left side of the street and leans on the building on the right side. The point where the two ladders cross is exactly c feet from the ground. How wide is the street?

Input

Input starts with an integer T (≤ 10), denoting the number of test cases.

Each test case contains three positive floating point numbers giving the values of xy, and c.

Output

For each case, output the case number and the width of the street in feet. Errors less than 10-6 will be ignored.

Sample Input

4

30 40 10

12.619429 8.163332 3

10 10 3

10 10 1

Sample Output

Case 1: 26.0328775442

Case 2: 6.99999923

Case 3: 8

Case 4: 9.797958971


题意:两栋楼之间有两个梯子,如图中的虚线所示,一个梯子的长度为x,另一个梯子的长度为y,两个梯子的交点离地面的高度为c,问两栋楼之间的距离。

这是一个几何题。设宽度为w,交点距左楼距离为a,则根据三角形相似可以推出:



把第二个式子代入第一个式子可以得出一个等式,看做时关于W的函数,求导可得是减函数。因为w一定小于x,y中的最小值(三角形的直角边小于斜边),二分求出答案。

#include<cstdio>
#include<math.h>
#include<algorithm>
using namespace std;
double x,y,c;
double check(double d)
{
	return 1-c/sqrt(y*y-d*d)-c/sqrt(x*x-d*d);
}
int main()
{
	double l,r,mid;
	int n,t;
	scanf("%d",&t);
	n=1;
	while(t--)
	{
		scanf("%lf%lf%lf",&x,&y,&c);
		r=min(x,y);
		l=0;
		printf("Case %d: ",n++);//
		while(r-l>0.00000001)
		{	
			mid=(l+r)/2;
			if(check(mid)>0)
			l=mid;
			if(check(mid)<0)
			r=mid;
		}
		printf("%lf\n",mid);
	}
		return 0;	
}




  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值