Sicily 1511. Conversions

6 篇文章 0 订阅
     
 
Time Limit: 1sec    Memory Limit:32MB
Description

Conversion between the metric and English measurement systems is relatively simple. Often, it involves either multiplying or dividing by a constant. You must write a program that converts between the following units:

 

Type Metric English equivalent
Weight 1.000 kilograms 2.2046 pounds
  0.4536 kilograms 1.0000 pound
Volume 1.0000 liter 0.2642 gallons
  3.7854 liters 1.0000 gallon
Input

The first line of input contains a single integer N , (1≤N≤1000) which is the number of datasets that follow.

Each dataset consists of a single line of input containing a floating point (double precision) number, a space and the unit specification for the measurement to be converted. The unit specification is one of kglbl, or g referring to kilograms, pounds, liters and gallons respectively.

Output

For each dataset, you should generate one line of output with the following values: The dataset number as a decimal integer (start counting at one), a space, and the appropriately converted value rounded to 4 decimal places, a space and the unit specification for the converted value.

Sample Input
 Copy sample input to clipboard
5 
1 kg 
2 l 
7 lb 
3.5 g 
0 l
Sample Output
1 2.2046 lb 
2 0.5284 g 
3 3.1752 kg 
4 13.2489 l 
5 0.0000 g

Problem Source: Greater New York 2007


// Problem#: 1511
// Submission#: 3685288
// The source code is licensed under Creative Commons Attribution-NonCommercial-ShareAlike 3.0 Unported License
// URI: http://creativecommons.org/licenses/by-nc-sa/3.0/
// All Copyright reserved by Informatic Lab of Sun Yat-sen University
#include<iostream>
#include<iomanip>
#include<string>
using namespace std;
int main(){
    int n;
    cin>>n;
    int i=1;
    while(n--){
        //int i=1;
        double a;
        string b;
        cin>>a>>b;
        if(b=="kg"){
            cout<<i<<" "<<fixed<<setprecision(4)<<a*2.2046<<" lb"<<endl;
        }
        else if(b=="l"){
            cout<<i<<" "<<fixed<<setprecision(4)<<a*0.2642<<" g"<<endl;
        }
        else if(b=="lb"){
            cout<<i<<" "<<fixed<<setprecision(4)<<a*0.4536<<" kg"<<endl;
        }
        else if(b=="g"){
            cout<<i<<" "<<fixed<<setprecision(4)<<a*3.7854<<" l"<<endl;
        }
        i++;
        
    }
    return 0;
}                                 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值