Sicily 1543. Completing Brackets

Description

A series of brackets is complete if we can pair off each left bracket '[' with a right bracket ']' that occurs later in the series. Every bracket must participate in exactly one such pair.

Given a String text add the minimal number of brackets to the beginning and/or end of text to make it complete. Return the result.

Input

Each line of input contains a string, text. text will have between 1 and 50 characters inclusive, and contain only the characters "[" and "]". Process to the end of input.

Output
Output one line for each case, the result.
Sample Input
 Copy sample input to clipboard
[[
][
[[[[]]]]
Sample Output
[[]]
[][]
[[[[]]]]

Problem Source: Topcoder SRM



// Problem#: 1543
// Submission#: 3685436
// The source code is licensed under Creative Commons Attribution-NonCommercial-ShareAlike 3.0 Unported License
// URI: http://creativecommons.org/licenses/by-nc-sa/3.0/
// All Copyright reserved by Informatic Lab of Sun Yat-sen University
#include<iostream>
#include<string>
#include<algorithm>
#include<cstdio>
#include<vector>
using namespace std;
int main(){
    string s;
    while(cin>>s){
        int count =0;
        int len=s.length();
        for(int i=0; i<len; i++){
            if(s[i]=='[')
            count++;
            else{
                count--;
            }
            if(count<0){
                cout<<"[";
                count++;
            }
        }
        cout<<s;
        while(count>0){
            cout<<"]";
            count--;
        }
        cout<<"\n";
    }
    return 0;
}                                 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值