题目描述
输入一个非负索引 rowIndex
,返回「杨辉三角」的第 rowIndex
行。
在「杨辉三角」中,每个数是它左上方和右上方的数的和。
输入格式
请在这里写输入指定的行(rowIndex,0为最小行)
输出格式
请在这里输出指定行的所有数字,以空格分开
输入样例1
在这里给出一组输入。例如:
0
输出样例1
在这里给出相应的输出。例如:
1
输入样例2
在这里给出一组输入。例如:
3
输出样例2
在这里给出相应的输出。例如:
1 3 3 1
AC code
/// 6-7 杨辉三角 ||
#include <bits/stdc++.h>
using namespace std;
int main()
{
int rowIndex;
cin>>rowIndex;
rowIndex++;
int vec[rowIndex+1][rowIndex+1] = {0};
for(int i=1; i<=rowIndex; i++)
{
vec[i][1] = 1;
for(int j=2; j<=i; j++)
{
vec[i][j] = vec[i-1][j] + vec[i-1][j-1];
}
}
for(int i=1; i<=rowIndex; i++)
{
cout<<vec[rowIndex][i];
if(i!=rowIndex)
cout<<" ";
}
return 0;
}