【洛谷刷题笔记】P5731 【深基5.习6】蛇形方阵
一、题目:
【深基5.习6】蛇形方阵
题目描述
给出一个不大于
9
9
9 的正整数
n
n
n,输出
n
×
n
n\times n
n×n
的蛇形方阵。
从左上角填上 1 1 1 开始,顺时针方向依次填入数字,如同样例所示。注意每个数字有都会占用 3 3 3 个字符,前面使用空格补齐。
输入格式
输入一个正整数 n n n,含义如题所述。
输出格式
输出符合题目要求的蛇形矩阵。
样例 #1
样例输入 #1
4
样例输出 #1
1 2 3 4
12 13 14 5
11 16 15 6
10 9 8 7
提示
数据保证, 1 ≤ n ≤ 9 1 \leq n \leq 9 1≤n≤9。
二、思路:
1.填数的顺序是右下左上,在while()内依次实现;
2.注意条件
三、源码:
#include <iostream>
#include <math.h>
using namespace std;
const int N = 15;
int arr[N][N];
int main() {
int in = 0;
int n = 0;
cin >> n;
int l = 0;
int r = 0;
//填数
arr[l][r] = 1;
int b = 2;
while (b <= n * n) {
while (arr[l][r + 1] == 0 && r < n - 1) {
arr[l][r + 1] = b;
b++;
r++;
}
while (arr[l + 1][r] == 0 && l < n - 1) {
arr[l + 1][r] = b;
b++;
l++;
}
while (arr[l][r - 1] == 0 && r > 0) {
arr[l][r - 1] = b;
b++;
r--;
}
while (arr[l - 1][r] == 0 && l > 0) {
arr[l - 1][r] = b;
b++;
l--;
}
}
//输出
for (int i = 0; i < n ; i++) {
for (int j = 0; j < n; j++) {
printf("%3d", arr[i][j]);
}
cout << endl;
}
return 0;
}
欢迎改正与补充