【代码超详解】POJ 3278 Catch That Cow(BFS,16 ms)

一、题目描述

Catch That Cow

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 159339 Accepted: 48608

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

  • Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
  • Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers: N and K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

Source

USACO 2007 Open Silver

二、算法分析说明与代码编写指导

在这里插入图片描述虽然这一题给的是一条一维的线段,但是仍然可以用 BFS 求解(本题求解花费的最短时间,把“时间”代入上述算法的“路径”)。
原来我脑抽在循环体内写的是:

a = std::max(0, q.front() - 1); b = std::min(100000, q.front() + 1); c = std::min(100000, 2 * q.front());
s = l[q.front()] + 1;
if (v[a] == 0) { l[a] = s; q.push(a); v[a] = 1; }
if (v[b] == 0) { l[b] = s; q.push(b); v[b] = 1; }
if (v[c] == 0) { l[c] = s; q.push(c); v[c] = 1; }
q.pop();

结果狂 WA 了很多发。跟别人的 AC 代码核对了很久才明白当超出范围的时候这样子写会在出界的时候把 0 或 100000 添加进去,从而给出错误结果。

三、AC 代码(16 ms)

#include<cstdio>
#include<queue>
#pragma warning(disable:4996)
int n, k, l[100001], a, b, c, s; std::queue<int> q;
int main() {
		scanf("%d%d", &n, &k);
		if (n >= k) { printf("%d\n", n - k); return 0; }
		q.push(n);
		while (q.empty() == false) {
			a = q.front() - 1; b = q.front() + 1; c = 2 * q.front();
			s = l[q.front()] + 1;
			if (a >= 0 && l[a] == 0) { l[a] = s; q.push(a); }
			if (b <= 100000 && l[b] == 0) { l[b] = s; q.push(b); }
			if (c <= 100000 && l[c] == 0) { l[c] = s; q.push(c); }
			q.pop();
		}
		printf("%d\n", l[k]);
		return 0;
	//}
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值