【代码超详解】POJ 1426 Find The Multiple(找规律递推,32 ms)

一、题目描述

Find The Multiple

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 56395 Accepted: 23320 Special Judge

Description

Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.

Input

The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.

Output

For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.

Sample Input

2
6
19
0

Sample Output

10
100100100100100100
111111111111111111

Source

Dhaka 2002

二、算法分析说明与代码编写指导

要为 n 寻找任意一个仅由 0,1 构成的倍数 m。设数列
在这里插入图片描述发现规律:
在这里插入图片描述
(注意分数线的意义是整除,与 C / C++ 的 / 运算符一致)
已知:在这里插入图片描述
设数列在这里插入图片描述
结合上述两条公式,得
在这里插入图片描述
已知递推起点在这里插入图片描述,设在这里插入图片描述
于是可以直接构造数列 {rx} ,当某一项为 0 时停止构造并输出。
观察数列 {mx} 的每一项的下标 i 的二进制表示都是 mi,所以可以直接输出 i 的二进制作为答案。

三、AC 代码

#include<cstdio>
#include<stack>
#pragma warning(disable:4996)
unsigned n, r[1 << 19] = { 0,1 }, R;
void output_bin(unsigned x) {
	static std::stack<unsigned> s;
	while (s.empty() == false)s.pop();
	while (x) {
		s.push(x & 1); x >>= 1;
	}
	while (s.empty() == false) {
		printf("%u", s.top()); s.pop();
	}
	putchar('\n');
}
int main() {
	for (;;) {
		scanf("%u", &n); if (n == 0)return 0;
		R = 10 % n;
		for (unsigned i = 2;; i += 2) {
			r[i] = R * r[i / 2] % n; if (r[i] == 0) { output_bin(i); break; }
			r[i + 1] = r[i] + 1; if (r[i] == 0) { output_bin(i); break; }
		}
	}
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值