有趣的数
时间限制:
3000 ms | 内存限制:
65535 KB
难度:
2
描述
把分数按下面的办法排成一个数表。
1/1 1/2 1/3 1/4.....
2/1 2/2 2/3....
3/1 3/2 ....
4/1.....
.........
我们以z字型方法给上表的每项编号。特定方法:第一项是1/1,然后是1/2、2/1、3/1、2/2、1/3、1/4、2/3……。编程输入项号N(1<=N<=100000),输出表中第N项。
-
输入
-
第一行有一个整数m(0<m<=10),表示有m组测试数据;
随后有m行,每行有一个整数N; -
输出
- 输出表中第N项
-
样例输入
4
3
14
7
12345
样例输出
2/1
2/4
1/4
59/99
import java.io.*;
import java.util.*;
public class Main {
public static int getN(int x){
if(x==1)
return 1;
else
return getN(x-1)+x;
}
public static void main(String[] args) {
Scanner cin = new Scanner(new BufferedInputStream(System.in));
int N = cin.nextInt();
ArrayList<String> arr = new ArrayList<String>();
for(int i=1;i<=447;i++){
if(i%2==0){
for(int j=1;j<=i;j++){
arr.add(j+"/"+(i+1-j));
}
}else{
for(int j=1;j<=i;j++){
arr.add((i+1-j)+"/"+j);
}
}
}
while(N-->0){
int n = cin.nextInt();
System.out.println(arr.get(n-1));
}
}
}