ACM学习感悟——POJ1932(图论)

Description

The prototypical computer adventure game, first designed by Will Crowther on the PDP-10 in the mid-1970s as an attempt at computer-refereed fantasy gaming, and expanded into a puzzle-oriented game by Don Woods at Stanford in 1976. (Woods had been one of the authors of INTERCAL.) Now better known as Adventure or Colossal Cave Adventure, but the TOPS-10 operating system permitted only six-letter filenames in uppercase. See also vadding, Zork, and Infocom.

It has recently been discovered how to run open-source software on the Y-Crate gaming device. A number of enterprising designers have developed Advent-style games for deployment on the Y-Crate. Your job is to test a number of these designs to see which are winnable.

Each game consists of a set of up to 100 rooms. One of the rooms is the start and one of the rooms is the finish. Each room has an energy value between -100 and +100. One-way doorways interconnect pairs of rooms.

The player begins in the start room with 100 energy points. She may pass through any doorway that connects the room she is in to another room, thus entering the other room. The energy value of this room is added to the player's energy. This process continues until she wins by entering the finish room or dies by running out of energy (or quits in frustration). During her adventure the player may enter the same room several times, receiving its energy each time.

Input

The input consists of several test cases. Each test case begins with n, the number of rooms. The rooms are numbered from 1 (the start room) to n (the finish room). Input for the n rooms follows. The input for each room consists of one or more lines containing:
  • the energy value for room i
  • the number of doorways leaving room i
  • a list of the rooms that are reachable by the doorways leaving room i

The start and finish rooms will always have enery level 0. A line containing -1 follows the last test case.

Output

In one line for each case, output "winnable" if it is possible for the player to win, otherwise output "hopeless".

Sample Input

5
0 1 2
-60 1 3
-60 1 4
20 1 5
0 0
5
0 1 2
20 1 3
-60 1 4
-60 1 5
0 0
5
0 1 2
21 1 3
-60 1 4
-60 1 5
0 0
5
0 1 2
20 2 1 3
-60 1 4
-60 1 5
0 0
-1

Sample Output

hopeless
hopeless
winnable
winnable	
	这道题其实是图论算法的综合应用吧。意思是求最长路是否大于零,那么建图的时候就可以吧权值变为负值,这样就可以用Bellmanford求最短路,但是题目还要判断是否可以到达终点,所以要先用Floyd来判断起点与重点之间是否联通,四轮清晰就比较容易理解。
AC代码:
	
/ 
//                           //                        //
//  Created by  Team 3 			                       //
//  Copyright (c) 2015年 Team 3. All rights reserved.  //
/
#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <cstdlib>           
#include <algorithm>
#include <cctype>
#include <stack>
#include <queue>
#include <map>
#include <string>
#include <set>
#include <vector>
#define INF 1<<31
#define cir(i,a,b)  for (int i=a;i<=b;i++)
#define CIR(j,a,b)  for (int j=a;j>=b;j--)
#define CLR(x) memset(x,0,sizeof(x))
typedef long long  ll;
using namespace std;
#define maxn 10000
int n;
int d[1005];
int t;
bool connect[1005][1005];
struct edge
{
	int u,v,w;
}g[10000]; 

bool Bellman()
{
	memset(d,0x3f,sizeof(d));
	d[1]=-100;
	for (int i=1;i<=n;i++)
		for (int j=1;j<t;j++)
		{
			if(d[g[j].v]>d[g[j].u]+g[j].w && d[g[j].u]+g[j].w<0)    //这里要判断下一步是否能够走,要保证走下一步是还有能量剩余。
			{
				d[g[j].v]=d[g[j].u]+g[j].w;
				if (i==n && connect[1][g[j].v] && connect[g[j].v][n])      //当执行到第n次时已经全部更新过,只需找到一条通路及最短路。 
				return true;
			}
		}
	return false;
}
int main()
{
	while (cin >> n && n!=-1 )
	{
		t=1;
		CLR(g);
		memset(connect,false,sizeof(connect));
		for (int i=1;i<=n;i++) connect[i][i]=true;
		for (int i=1;i<=n;i++)
		{
			int cost,m,v;
			cin >> cost >> m;
			for (int j=1;j<=m;j++)
			{
				cin >> v;
				connect[i][v]=true;
				g[t].u=i;
				g[t].v=v;
				g[t].w=-cost;
				t++;
			} 
		}
		for (int k=1;k<=n;k++)
			for (int i=1;i<=n;i++)
				for (int j=1;j<=n;j++)
				if (connect[i][k]&&connect[k][j])
					connect[i][j]=true;
		if (connect[1][n])
		{
			if (Bellman() || d[n]<0) cout << "winnable\n";
			else cout << "hopeless\n";
		} 
		else 
			cout << "hopeless\n";
	} 
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值