字符串dp。



Description

Few know that the cows have their own dictionary with W (1 ≤ W ≤ 600) words, each containing no more 25 of the characters 'a'..'z'. Their cowmunication system, based on mooing, is not very accurate; sometimes they hear words that do not make any sense. For instance, Bessie once received a message that said "browndcodw". As it turns out, the intended message was "browncow" and the two letter "d"s were noise from other parts of the barnyard.

The cows want you to help them decipher a received message (also containing only characters in the range 'a'..'z') of length L (2 ≤ L ≤ 300) characters that is a bit garbled. In particular, they know that the message has some extra letters, and they want you to determine the smallest number of letters that must be removed to make the message a sequence of words from the dictionary.

Input

Line 1: Two space-separated integers, respectively: W and L
Line 2: L characters (followed by a newline, of course): the received message
Lines 3..
W +2: The cows' dictionary, one word per line

Output

Line 1: a single integer that is the smallest number of characters that need to be removed to make the message a sequence of dictionary words.

Sample Input

6 10
browndcodw
cow
milk
white
black
brown
farmer

Sample Output


又是一道新类型,由此写此篇。
这是一道字符串dp 比较恶心,题目大意是,给出6表示牛的词汇,给出10表示 牛说的一串话(有多余的字母)然后你的任务就是 从这一串话中找到最少的多余字母的个数
这道题,用dp[i]表示从第i个字母开始,到最后一个字母结束, 的最少多余字母的状态,
那么从第m个字母倒着来的话,这个问题就转为dp[i]=min(dp[i+1]+1,dp[i1]+i1-i-len(word[k]))
枚举牛的词汇,然后以第i个字母开始 第i1-1个字母结束(删掉某些字母形成第k个词汇)那么删掉的字母数就是i1-i-len(word[k]) 在加上dp[i1]即可求出dp[i]的最小值,
这道题,输入被自己坑了 debug3小时, 还是太年轻了。哎
代码如下:
 //
// Create by ÉñÖÛ on 2015-02-15
//
#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <cstdlib>
#include <algorithm>
#include <cctype>
#include <stack>
#include <queue>
#include <map>
#include <string>
#include <set>
#include <vector>
using namespace std;
#define CLR(x) memset(x,0,sizeof x)
#define ll long long
#define inf 0x3f3f3f3f
const int maxn=1e3+5;
const int MOD=5e5+5;
char dic[2*maxn][maxn],word[maxn];
int dp[maxn*2];
int len[maxn*2];
int main()
{
#ifdef LOCAL
 freopen("in.txt","r",stdin);
 //freopen("out.txt","w",stdout);
#endif
 ios_base::sync_with_stdio(0);
 int n,m;
 while(scanf("%d%d",&n,&m)!=EOF){
        CLR(len);
        CLR(dic);
        CLR(word);
        CLR(dp);
        scanf("%s",word+1);
        for(int i=1;i<=n;i++){
            scanf("%s",dic[i]+1);
            len[i]=strlen(dic[i]+1);
        }
        for(int i=m;i>0;i--){
            dp[i]=dp[i+1]+1;
            for(int j=1;j<=n;j++){
                if(m-i+1>=len[j]&&word[i]==dic[j][1]){
                    int i1=i,i2=1;
                    //printf("%d\n\n\n",i1);
                    while(i1<=m){
                        if(dic[j][i2]==word[i1++]) i2++;
                        //printf("%d\t%d\n\n",i1,i2);
                        if(i2==len[j]+1){
                            dp[i]=min(dp[i],dp[i1]+i1-i-len[j]);
                        }
                    }
                }
            }
        }
        printf("%d\n",dp[1]);
 }
 return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值