1628: [Usaco2007 Demo]City skyline

1628: [Usaco2007 Demo]City skyline

Time Limit: 5 Sec   Memory Limit: 64 MB
Submit: 348   Solved: 284
[ Submit][ Status][ Discuss]

Description

Input

第一行给出N,W
第二行到第N+1行:每行给出二个整数x,y,输入的x严格递增,并且第一个x总是1

Output

输出一个整数,表示城市中最少包含的建筑物数量

Sample Input

10 26
1 1
2 2
5 1
6 3
8 1
11 0
15 2
17 3
20 2
22 1

INPUT DETAILS:

The case mentioned above

Sample Output

6

HINT

Source

 

单调栈。。。一个月前居然傻逼的写不出来。。
#include<stack>
#include<cstdio>
#include<iostream>
using namespace std;

const int maxn = 5e4 + 50;

long long ans = 0;
int x[maxn],y[maxn],n,i,j,w;
stack <int> s;

int main()
{
	#ifdef YZY
		freopen("yzy.txt","r",stdin);
	#endif
	cin >> n >> w;
	for (i = 1; i <= n; i++) scanf("%d%d",&x[i],&y[i]);
	y[i] = 0;
	for (i = 1; i <= n + 1; i++)
	{
		if (s.empty())
		{
			s.push(i);
			continue;
		}
		int tail = 1E9;
		while (!s.empty() && y[s.top()] > y[i])
		{
			int T = y[s.top()];
			s.pop();
			if (T != tail) tail = T,++ans;
		}
		s.push(i);
	}
	cout << ans;
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值