2081: [Poi2010]Beads
Time Limit: 10 Sec Memory Limit: 259 MBSubmit: 495 Solved: 192
[ Submit][ Status][ Discuss]
Description
Zxl有一次决定制造一条项链,她以非常便宜的价格买了一长条鲜艳的珊瑚珠子,她现在也有一个机器,能把这条珠子切成很多块(子串),每块有k(k>0)个珠子,如果这条珠子的长度不是k的倍数,最后一块小于k的就不要拉(nc真浪费),保证珠子的长度为正整数。 Zxl喜欢多样的项链,为她应该怎样选择数字k来尽可能得到更多的不同的子串感到好奇,子串都是可以反转的,换句话说,子串(1,2,3)和(3,2,1)是一样的。写一个程序,为Zxl决定最适合的k从而获得最多不同的子串。 例如:这一串珠子是: (1,1,1,2,2,2,3,3,3,1,2,3,3,1,2,2,1,3,3,2,1), k=1的时候,我们得到3个不同的子串: (1),(2),(3) k=2的时候,我们得到6个不同的子串: (1,1),(1,2),(2,2),(3,3),(3,1),(2,3) k=3的时候,我们得到5个不同的子串: (1,1,1),(2,2,2),(3,3,3),(1,2,3),(3,1,2) k=4的时候,我们得到5个不同的子串: (1,1,1,2),(2,2,3,3),(3,1,2,3),(3,1,2,2),(1,3,3,2)
Input
共有两行,第一行一个整数n代表珠子的长度,(n<=200000),第二行是由空格分开的颜色ai(1<=ai<=n)。
Output
也有两行,第一行两个整数,第一个整数代表能获得的最大不同的子串个数,第二个整数代表能获得最大值的k的个数,第二行输出所有的k(中间有空格)。
Sample Input
21
1 1 1 2 2 2 3 3 3 1 2 3 3 1 2 2 1 3 3 2 1
1 1 1 2 2 2 3 3 3 1 2 3 3 1 2 2 1 3 3 2 1
Sample Output
6 1
2
2
HINT
Source
#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cmath>
#include<cstring>
#include<vector>
#include<queue>
#include<set>
#include<map>
#include<stack>
#include<bitset>
#include<ext/pb_ds/priority_queue.hpp>
using namespace std;
const int maxn = 2E5 + 20;
typedef long long LL;
const int mo = 98754321;
const int p = 2333;
int h[maxn],_h[maxn],mi[maxn],A[maxn];
int n,tp,Max,Ans[maxn],s[maxn];
map <int,bool> mp;
int Mul(const LL &x,const LL &y) {return x * y % mo;}
int Add(const int &x,const int &y) {return (x + y) % mo;}
int Dec(const int &x,const int &y) {return (x - y + mo) % mo;}
int Geth(int l,int r)
{
int len = r - l + 1;
return Dec(h[r],Mul(h[l-1],mi[len]));
}
int Get_h(int l,int r)
{
int len = r - l + 1;
return Dec(_h[l],Mul(_h[r+1],mi[len]));
}
int getint()
{
char ch = getchar(); int ret = 0;
while (ch < '0' || '9' < ch) ch = getchar();
while ('0' <= ch && ch <= '9')
ret = ret*10 + ch - '0',ch = getchar();
return ret;
}
int main()
{
#ifdef DMC
freopen("DMC.txt","r",stdin);
#endif
cin >> n; mi[0] = 1;
for (int i = 1; i <= n; i++)
s[i] = getint(),mi[i] = Mul(mi[i-1],p);
for (int i = 1; i <= n; i++) h[i] = Add(Mul(h[i-1],p),s[i]);
for (int i = n; i; i--) _h[i] = Add(Mul(_h[i+1],p),s[i]);
for (int k = 1; k <= n; k++)
{
int cnt = 0; mp.clear();
if (n / k < Max) break;
for (int j = 1; j + k - 1 <= n; j += k)
{
int h1 = Geth(j,j + k - 1);
int h2 = Get_h(j,j + k - 1);
if (!mp[h1] || !mp[h2])
++cnt,mp[h1] = mp[h2] = 1;
}
if (cnt > Max) Max = cnt,Ans[tp = 1] = k;
else if (cnt == Max) Ans[++tp] = k;
}
printf("%d %d\n",Max,tp);
for (int i = 1; i < tp; i++) printf("%d ",Ans[i]); cout << Ans[tp];
return 0;
}