poj_1258 Agri-Net

Agri-Net

Time Limit: 1000MS

Memory Limit: 10000K

Total Submissions: 28121

Accepted: 11149

题目链接:http://poj.org/problem?id=1258

Description

Farmer John has been electedmayor of his town! One of his campaign promises was to bring internetconnectivity to all farms in the area. He needs your help, of course.
Farmer John ordered a high speed connection for his farm and is going to sharehis connectivity with the other farmers. To minimize cost, he wants to lay theminimum amount of optical fiber to connect his farm to all the other farms.
Given a list of how much fiber it takes to connect each pair of farms, you mustfind the minimum amount of fiber needed to connect them all together. Each farmmust connect to some other farm such that a packet can flow from any one farmto any other farm.
The distance between any two farms will not exceed 100,000.

Input

The input includes severalcases. For each case, the first line contains the number of farms, N (3 <= N<= 100). The following lines contain the N x N conectivity matrix, whereeach element shows the distance from on farm to another. Logically, they are N linesof N space-separated integers. Physically, they are limited in length to 80characters, so some lines continue onto others. Of course, the diagonal will be0, since the distance from farm i to itself is not interesting for thisproblem.

Output

For each case, output a singleinteger length that is the sum of the minimum length of fiber required toconnect the entire set of farms.

Sample Input

4

0 4 9 21

4 0 8 17

9 8 0 16

21 17 16 0

Sample Output

28

Source

USACO102

解题思路:

         给你一张图,求最短路径,这是一到典型的求最短路径模版体,用prim()算法就能过。

代码:

#include <iostream>
#include<cstdio>
#include<cstring>
#define MAX 103
#define VALUE 0xfffff
using namespace std;

int g[MAX][MAX];
int visited[MAX];
int minCost[MAX];
int prim(int n)
{
    int i;
    for(i=0;i<n;i++)
    {
        visited[i]=0;
        minCost[i]=VALUE;
    }
    minCost[0]=0;
    int res=0;
    while(true)
    {
        int t=-1;
        for(i=0;i<n;i++)
        {
            if(visited[i]==0 && (t==-1 || minCost[i]<minCost[t]))
            {
                t=i;
            }
        }
        if(t==-1)
            break;
        visited[t]=1;
        res+=minCost[t];
        for(i=0;i<n;i++)
        {
            if(minCost[i]>g[i][t] && g[i][t]!=0)
            {
                minCost[i]=g[i][t];
            }
        }
    }
    return res;
}

int main()
{
    int i,j;
    int n;
    while(scanf("%d",&n)!=EOF)
    {
        memset(g,0,sizeof(g));
        for(i=0;i<n;i++)
        {
            for(j=0;j<n;j++)
            {
                scanf("%d",&g[i][j]);
            }
        }
        printf("%d\n",prim(n));
    }
    return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

疯的世界

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值