poj_2240 Arbitrage

Arbitrage

Time Limit: 1000MS

Memory Limit: 65536K

Total Submissions: 10954

Accepted: 4608

题目链接:http://poj.org/problem?id=2240

Description

Arbitrage is the use of discrepancies in currencyexchange rates to transform one unit of a currency into more than one unit ofthe same currency. For example, suppose that 1 US Dollar buys 0.5 Britishpound, 1 British pound buys 10.0 French francs, and 1 French franc buys 0.21 USdollar. Then, by converting currencies, a clever trader can start with 1 USdollar and buy 0.5 * 10.0 * 0.21 = 1.05 US dollars, making a profit of 5percent.

Your job is to write a program that takes a list of currency exchange rates asinput and then determines whether arbitrage is possible or not.

Input

The input will contain one or more test cases. Om thefirst line of each test case there is an integer n (1<=n<=30),representing the number of different currencies. The next n lines each containthe name of one currency. Within a name no spaces will appear. The next linecontains one integer m, representing the length of the table to follow. Thelast m lines each contain the name ci of a source currency, a real number rijwhich represents the exchange rate from ci to cj and a name cj of thedestination currency. Exchanges which do not appear in the table areimpossible.
Test cases are separated from each other by a blank line. Input is terminatedby a value of zero (0) for n.

Output

For each test case, print one line telling whetherarbitrage is possible or not in the format "Case case: Yes"respectively "Case case: No".

Sample Input

3

USDollar

BritishPound

FrenchFranc

3

USDollar 0.5 BritishPound

BritishPound 10.0 FrenchFranc

FrenchFranc 0.21 USDollar

 

3

USDollar

BritishPound

FrenchFranc

6

USDollar 0.5 BritishPound

USDollar 4.9 FrenchFranc

BritishPound 10.0 FrenchFranc

BritishPound 1.99 USDollar

FrenchFranc 0.09 BritishPound

FrenchFranc 0.19 USDollar

 

0

Sample Output

Case 1: Yes

Case 2: No

Source

Ulm Local 1996

题意:

就是将货币兑换,问这样兑换能否盈利

解题思路:

         根据题意给出的字符串建立图,在用flody算法计算任意两个点之间的距离,用乘号不用加号,最后变量一遍图中(i,i)节点,如果有存在大于1的就输出Yes,否则输出No

代码:

#include <iostream>
#include<cstdio>
#include<cstring>
#include<queue>
#define MAX 40
#define VALUE 0xffffff
using namespace std;
struct word
{
    int id;
    char wd[50];
};
word w[MAX];
double g[MAX][MAX];
int n;

void flody()
{
	for(int k=1;k<=n;k++)
	{
		for(int j=1;j<=n;j++)
		{
			for(int i=1;i<=n;i++)
			{
				if(g[i][j]<g[i][k]*g[k][j])
				{
					g[i][j]=g[i][k]*g[k][j];
				}
			}
		}
	}
}

int getId(char *wd)
{
    for(int i=1;i<=n;i++)
    {
        if(strcmp(wd,w[i].wd)==0)
            return w[i].id;
    }
	return 0;
}


int main()
{
    int i;
	char a[MAX],b[MAX];
	float rate;
	int flag=1;
    while(true)
    {
		memset(g,0,sizeof(g));
        scanf("%d",&n);
		
        if(n==0)
            break;
		getchar();
        for(i=1;i<=n;i++)
        {
            gets(w[i].wd);
            w[i].id=i;
        }
        int count;
        scanf("%d",&count);
        while(count--)
        {
			getchar();
			cin>>a>>rate>>b;
			int id1=getId(a);
			int id2=getId(b);
			g[id1][id2]=rate;
        }
		flody();

		for(i=1;i<=n;i++)
		{
			if(g[i][i]>1)
			{
				printf("Case %d: Yes\n",flag);
				break;
			}
		}
		if(i==(n+1))
		{
			printf("Case %d: No\n",flag);
		}
		flag++;

    }
    return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

疯的世界

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值