概率水题

A - Play the Dice

时间限制:2000 MS
内存限制:65535 MB

问题描述

There is a dice with N sides, which are numbered from 1,2,...,n and have the equal possibility to show up when one rolls a dice. Each side has an integer A i on it. Now here is a game that you can roll this dice once, if the i-th side is up, you will get A i yuan. What's more, some sids of this dice are colored with a special different color. If you turn this side up, you will get once more chance to roll the dice. When you roll the dice for the second time, you still have the opportunity to win money and rolling chance. Now you need to calculate the expectations of money that we get after playing the game once.

输入说明

Input consists of multiple cases. Each case includes two lines. End with EOF.
The first line is an integer N (2<=N<=200), following with N integers A i(0<=A i<200)
The second line is an integer M (0<=M<=N), following with m integers B i(1<=B i<=n), which are the numbers of the special sides to get another more chance.

输出说明

Just a real number which is the expectations of the money one can get, rounded to exact two digits. If you can get unlimited money, print "inf" a line without double quotes.

输入样例

6 1 2 3 4 5 6
0
4 0 0 0 0
1 3

输出样例

3.50
0.00

 

题目链接:http://icpc.njust.edu.cn/Contest/194/Problem/A

 

很简单的数学题。

很快可以推出公式,水题。

设所求期望为ans

那么

ans=1/N *(A[B[1]]+ans) + 1/N *(A[B[2]]+ans)  + ...1/N *(A[B[M]]+ans) + 1/N A[k]+....

ans=M/N *ans+1/N*(A[1]+A[2]+A[3]+....+A[N]);

(N-M)ans= A[1]+A[2]+...+A[N]=sum;

如果sum==0,答案为0.00

如果sum!=0,N-M==0  答案为inf

否则答案就是sum/(N-M);

 

复制代码
#include <stdio.h>
#include <algorithm>
#include <iostream>
#include <string.h>
using namespace std;
const int MAXN=220;
int a[MAXN],b[MAXN];
int main()
{
    int n,m;
    while(scanf("%d",&n)==1)
    {
        int sum=0;
        for(int i=0;i<n;i++)
        {
            scanf("%d",&a[i]);
            sum+=a[i];
        }
        scanf("%d",&m);
        for(int i=0;i<m;i++)
          scanf("%d",&b[i]);
        if(sum==0)
        {
            printf("0.00\n");
            continue;
        }
        if(n==m)
        {
            printf("inf\n");
            continue;
        }
        printf("%.2lf\n",(double)sum/(n-m));
    }
    return 0;
}
总结:可采用数学设立未知数,根据所给数据之间的关系列等式的方法计算未知值的大小。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值