POJ 1654 Area计算几何(解题报告)

Description

You are going to compute the area of a special kind of polygon. One vertex of the polygon is the origin of the orthogonal coordinate system. From this vertex, you may go step by step to the following vertexes of the polygon until back to the initial vertex. For each step you may go North, West, South or East with step length of 1 unit, or go Northwest, Northeast, Southwest or Southeast with step length of square root of 2.

For example, this is a legal polygon to be computed and its area is 2.5:

Input

The first line of input is an integer t (1 <= t <= 20), the number of the test polygons. Each of the following lines contains a string composed of digits 1-9 describing how the polygon is formed by walking from the origin. Here 8, 2, 6 and 4 represent North, South, East and West, while 9, 7, 3 and 1 denote Northeast, Northwest, Southeast and Southwest respectively. Number 5 only appears at the end of the sequence indicating the stop of walking. You may assume that the input polygon is valid which means that the endpoint is always the start point and the sides of the polygon are not cross to each other.Each line may contain up to 1000000 digits.

Output

For each polygon, print its area on a single line.

Sample Input

4
5
825
6725
6244865

Sample Output

0
0
0.5
2
  计算几何的经典题目,题目的意思是从一个点开始移动,可以移动八个方向,题目给出移动的方向
要求的是移动后构成的多边形的面积。这个题不记得叉积可以求面积了,衰,,,具体见代码吧,不难:

#include<iostream>
#include<stdio.h>
#include<string.h>
using namespace std;
struct point 
{
	int x,y;
};
 
int det(point a,point b)
{//叉积求面积 
	return a.x*b.y-a.y*b.x;
}
//记录移动的坐标 
int stand[10][2]={{0,0},{-1,-1},{0,-1},{1,-1},{-1,0},{0,0},{1,0},{-1,1},{0,1},{1,1}};
int main()
{
	char a[1000001];
	int i,t,n,str;
	scanf("%d",&t);
	point pointone,pointtwo;
	while(t--)
	{
		long long s=0;
		scanf("%s",&a);
		str=strlen(a);
		if(str==1||str==2)//小于3 肯定是0; 
		{
			printf("0\n");
			continue;
		}
		for(i=0;i<str-1;i++)
		{
			if(i==0)
			{
				pointone.x=stand[a[i]-'0'][0];
				pointone.y=stand[a[i]-'0'][1];
			}
			else 
			{//开始求面积 
				pointtwo.x=pointone.x+stand[a[i]-'0'][0];
				pointtwo.y=pointone.y+stand[a[i]-'0'][1];
				s+=det(pointone,pointtwo);
				pointone=pointtwo;
			}
		}
		long long temp;
		if(s<0)
		{
			s=-s;
		}
		temp=s/2;
		if(temp*2==s)
		{
			printf("%lld\n",s/2);
		}
		else
		{
			printf("%lld.5\n",s/2);
		}
	}
	return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值