POJ 1850 Code组合数学(解题报告)

Description

Transmitting and memorizing information is a task that requires different coding systems for the best use of the available space. A well known system is that one where a number is associated to a character sequence. It is considered that the words are made only of small characters of the English alphabet a,b,c, …, z (26 characters). From all these words we consider only those whose letters are in lexigraphical order (each character is smaller than the next character).

The coding system works like this:
• The words are arranged in the increasing order of their length.
• The words with the same length are arranged in lexicographical order (the order from the dictionary).
• We codify these words by their numbering, starting with a, as follows:
a – 1
b – 2

z – 26
ab – 27

az – 51
bc – 52

vwxyz – 83681

Specify for a given word if it can be codified according to this coding system. For the affirmative case specify its code.

Input

The only line contains a word. There are some constraints:
• The word is maximum 10 letters length
• The English alphabet has 26 characters.

Output

The output will contain the code of the given word, or 0 if the word can not be codified.

Sample Input

bf

Sample Output

55
  这是一道考察组合数学的题目,题目的意思是26个字母升序排列,字母的个数可以是1,2,3,4。。。最后求******是排在第几位。这个题目的话拿bcdef来举例子吧。
咱们要求这个字符串的序列,是不是可以先把vwxyz的序号求出来,这个很简单就是c(26,1)+c(26,2)+c(26,3)+c(26,4)+c(26,5)。现在求出来了,咱们是不是只要把bcdef到vwxyz的字符串的数量减去就好了呢,答案是显然的,看代码吧:
#include<iostream>
#include<stdio.h>
#include<string.h>
using namespace std;
 
__int64 factorial(int n,int m)
{
	__int64 sum=1;
	int i;
	for(i=n;i>n-m;i--)
	{
		sum*=i;
	}
	return sum;
}
 
__int64 factorial2(int n)
{
	__int64 sum=1;
	int i;
	for(i=n;i>=2;i--)
	{
		sum*=i;
	}
	return sum;
}
 
__int64 factorial3(int n,int i)
{
	return factorial(n,i)/factorial2(i);
}
 
int main()
{
	char a[100];
	int str,i,j;
	__int64 sum;
	//cout<<factorial(26,1)/factorial2(1)<<endl;
	scanf("%s",a);
	str=strlen(a);
	sum=0;
	int flag=0; 
	for(i=1;i<str;i++)//判断是不是升序
	{
		if(a[i]<a[i-1])
		{
			flag=1;
			break;
		}
	}
	if(flag)
	{
		printf("0\n");
	}
	else
	{
		for(i=1;i<=str;i++)//求出到str这么多字符的所有数量
	   {
		   sum+=factorial3(26,i);
	   }
		//printf("%I64d\n",sum);
	   for(i=1,j=str-1;j>=0;j--)//减去多了的
	   {
			sum-=factorial3('z'-a[j],i);
			i++;
		}
			printf("%I64d",sum);
	}
 
	return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值