PAT L2-004. 这是二叉搜索树吗?

L2-004. 这是二叉搜索树吗?

时间限制
400 ms
内存限制
65536 kB
代码长度限制
8000 B
判题程序
Standard
作者
陈越

一棵二叉搜索树可被递归地定义为具有下列性质的二叉树:对于任一结点,

  • 其左子树中所有结点的键值小于该结点的键值;
  • 其右子树中所有结点的键值大于等于该结点的键值;
  • 其左右子树都是二叉搜索树。

所谓二叉搜索树的“镜像”,即将所有结点的左右子树对换位置后所得到的树。

给定一个整数键值序列,现请你编写程序,判断这是否是对一棵二叉搜索树或其镜像进行前序遍历的结果。

输入格式:

输入的第一行给出正整数N(<=1000)。随后一行给出N个整数键值,其间以空格分隔。

输出格式:

如果输入序列是对一棵二叉搜索树或其镜像进行前序遍历的结果,则首先在一行中输出“YES”,然后在下一行输出该树后序遍历的结果。数字间有1个空格,一行的首尾不得有多余空格。若答案是否,则输出“NO”。

输入样例1:
7
8 6 5 7 10 8 11
输出样例1:
YES
5 7 6 8 11 10 8
输入样例2:
7
8 10 11 8 6 7 5
输出样例2:
YES
11 8 10 7 5 6 8
输入样例3:
7
8 6 8 5 10 9 11
输出样例3:
NO
#include<iostream>
using namespace std;
struct node
{
	int num;
	node *lchild;
	node *rchild;
	node(node *Lchild = NULL, node *Rchild = NULL) { lchild = Lchild;rchild = Rchild; };
};
void createA(node* &root, int num1)
{
	if (root == NULL)
	{
		root = new node;
		root->num = num1;
		return;
	}
	if (num1 <root->num)
		createA(root->lchild,num1);
	else
		createA(root->rchild,num1);
}
void createB(node* &root, int num1)
{
	if (root == NULL)
	{
		root = new node;
		root->num = num1;
		return;
	}
	if (num1 >=root->num)
		createB(root->lchild, num1);
	else
		createB(root->rchild, num1);
}
void Preorder(node *root, int arr[],int &count)
{
	if (root == NULL)
		return;
	count++;
	arr[count] = root->num;
	Preorder(root->lchild, arr,count);
	Preorder(root->rchild, arr,count);
}
void Print(node *root, int &count)
{
	if (root == NULL)
		return;
	Print(root->lchild, count);
	Print(root->rchild, count);
	if (count - 1)
	{
		cout << root->num << " ";
		count--;
	}
	else
		cout << root->num;
}
int main()
{
	int N,q=-1;
	cin >> N;
	int *count=new int[N];
	int *count1 = new int[N];
	int *count2 = new int[N];
	bool button1 = true, button2 = true;
	for (int i = 0;i < N;i++)
		cin >> count[i];
	node *root1 = new node;
	node *root2 = new node;
	root1->num = count[0];
	root2->num = count[0];
	for (int i = 1;i < N;i++)
	{
		createA(root1, count[i]);
		createB(root2, count[i]);
	}
	Preorder(root1,count1, q);
	q = -1;
	Preorder(root2, count2, q);
	for(int i=0;i<N;i++)
		if (count1[i] != count[i])
		{
			button1 = false;
			break;
		}
	for (int i = 0;i<N;i++)
		if (count2[i] != count[i])
		{
			button2 = false;
			break;
		}
	if (button1||button2)
	{
		cout << "YES" << endl;
		(button1 == true) ? Print(root1, N) : Print(root2, N);
	}
	else
		cout << "NO";
	system("PAUSE");
	return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值