PAT L2-006. 树的遍历

L2-006. 树的遍历

时间限制
400 ms
内存限制
65536 kB
代码长度限制
8000 B
判题程序
Standard
作者
陈越

给定一棵二叉树的后序遍历和中序遍历,请你输出其层序遍历的序列。这里假设键值都是互不相等的正整数。

输入格式:

输入第一行给出一个正整数N(<=30),是二叉树中结点的个数。第二行给出其后序遍历序列。第三行给出其中序遍历序列。数字间以空格分隔。

输出格式:

在一行中输出该树的层序遍历的序列。数字间以1个空格分隔,行首尾不得有多余空格。

输入样例:
7
2 3 1 5 7 6 4
1 2 3 4 5 6 7
输出样例:
4 1 6 3 5 7 2
思路:通过递归函数来确定后序和中续下唯一的二叉树,然后用队列来层次遍历。
#include<iostream>
#include<queue>
using namespace std;
struct node
{
	int num;
	node *lchild;
	node *rchild;
	node(node *Lchild = NULL, node *Rchild = NULL) {
		lchild = Lchild;
		rchild = Rchild;
	}
};
void Sort(node* &Root, int Post[], int Mid[],int start,int end,int& k)
{
	if ((start > end)||(end<0))
	{
		k++;
		return;
	}
	int m=0;
	while (Mid[m] != Post[k])
		m++;
	if (Root == NULL)
		Root = new node;
	Root->num = Mid[m];
	Sort(Root->rchild, Post, Mid, m+1,end,--k);
	Sort(Root->lchild, Post, Mid, start, m-1, --k);
}
int main()
{
	int count,count1, k = 0;
	cin >> count;
	count1 = count - 1;
	int *post = new int[count];
	int *mid = new int[count];
	queue<node*> print;
	for (int i = 0;i < count;i++)
		cin >> post[i];
	for (int i = 0;i < count;i++)
		cin >> mid[i];
	node *root = new node;
	Sort(root, post, mid,0,count1,count1);
	print.push(root);
	while (!print.empty())
	{
		node *t = print.front();
		if(t->lchild!=NULL)
		print.push(t->lchild);
		if (t->rchild != NULL)
		print.push(t->rchild);
		print.pop();
		if (print.empty())
			cout << t->num;
		else
			cout << t->num << " ";
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值