人生第一道 DP

#POJ 1163
题面:

7
3 8
8 1 0
2 7 4 4
4 5 2 6 5

(Figure 1)

Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right.

Input
Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle, all integers, are between 0 and 99.

Output
Your program is to write to standard output. The highest sum is written as an integer.

Sample Input

5
7
3 8
8 1 0
2 7 4 4
4 5 2 6 5

Sample Output

30

题意:
给一个类似于杨辉三角的一个三角形,求出从最上层到最下层中和的最大值

刚开始用了DFS,直接TE,嘛,没话说,果然还是too young too simple.

然后发现这个是一个很典型的DP.

然而,

鄙人并没有写过DP.

但是,凡事总要有开头,便试了一下。

//POJ 1163
#include<iostream>
#include<string>
#include<algorithm>

using namespace std;
int graph[102][102];
int num[102][102];
int n;

int main(){
    ios::sync_with_stdio(false);
    cin>>n;
    //读取输入。
    for(int count1=1;count1<=n;++count1){
        int count2;
        for(int count2=1;count2<=count1;++count2){
            cin>>graph[count1][count2];
        }
    }
    //开始打牌了!!
    num[1][1]=graph[1][1];  //给一个初始值,作为起点
    for(int cu=2;cu<=n;++cu){
        num[cu][1]=num[cu-1][1]+graph[cu][1];
        num[cu][cu]=num[cu-1][cu-1]+graph[cu][cu];
        for(int count1=2;count1<cu;++count1){
            num[cu][count1]=max(num[cu-1][count1-1],num[cu-1][count1])+graph[cu][count1];
        }
    }
    int ans=0;
    for(int count1=1;count1<=n;++count1){
        if(num[n][count1]>ans)ans=num[n][count1];
    }
    cout<<ans<<"\n";
}

最后16MS过的,不过我已经心满意足了。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值