1047 Student List for Course (25 分) vector的运用+统计+排序

题目

Zhejiang University has 40,000 students and provides 2,500 courses. Now given the registered course list of each student, you are supposed to output the student name lists of all the courses.

Input Specification:
Each input file contains one test case. For each case, the first line contains 2 numbers: N ( ≤ 40 , 000 ) N (≤40,000) N(40,000), the total number of students, and K ( ≤ 2 , 500 ) K (≤2,500) K(2,500), the total number of courses. Then N lines follow, each contains a student’s name (3 capital English letters plus a one-digit number), a positive number C ( ≤ 20 ) C (≤20) C(20) which is the number of courses that this student has registered, and then followed by C course numbers. For the sake of simplicity, the courses are numbered from 1 to K.

Output Specification:
For each test case, print the student name lists of all the courses in increasing order of the course numbers. For each course, first print in one line the course number and the number of registered students, separated by a space. Then output the students’ names in alphabetical order. Each name occupies a line.

Sample Input:

10 5
ZOE1 2 4 5
ANN0 3 5 2 1
BOB5 5 3 4 2 1 5
JOE4 1 2
JAY9 4 1 2 5 4
FRA8 3 4 2 5
DON2 2 4 5
AMY7 1 5
KAT3 3 5 4 2
LOR6 4 2 4 1 5

Sample Output:

1 4
ANN0
BOB5
JAY9
LOR6
2 7
ANN0
BOB5
FRA8
JAY9
JOE4
KAT3
LOR6
3 1
BOB5
4 7
BOB5
DON2
FRA8
JAY9
KAT3
LOR6
ZOE1
5 9
AMY7
ANN0
BOB5
DON2
FRA8
JAY9
KAT3
LOR6
ZOE1

解题思路

  题目大意: 给你N个学生的选课课表,统计出没一门课有哪些学生选。
  解题思路: 课程K的上限是2500,显然可以直接用vector,人数也是相当有限的4000,而且时间限制给到了1000ms,那还等什么?不如直接暴力统计就好了,注意最后一个测试点数据量比较大,不要使用cout和cin就没问题,同时注意string的scanf的搭配会有一定的水土不服。

/*
** @Brief:No.1047 of PAT advanced level.
** @Author:Jason.Lee
** @Date:2018-12-19
** @Solution:https://blog.csdn.net/CV_Jason/article/details/85101228
*/

#include<iostream>
#include<vector>
#include<algorithm>

using namespace std;

int main(){
	int N,K;
	while(scanf("%d%d",&N,&K)!=EOF){
		vector<string> course[K+1];
		for(int i=0;i<N;i++){
			char temp[5];
			int C;
			scanf("%s %d",temp,&C);
			string name(temp);
			for(int j=0;j<C;j++){
				int course_i;
				scanf("%d",&course_i);
				course[course_i].push_back(name);
			}
		}

		for(int i=1;i<=K;i++){
			sort(course[i].begin(),course[i].end(),[](string a,string b){return a<b;});
			int size = course[i].size();
			printf("%d %d\n",i,size);
			for(int j=0;j<size;j++){
				printf("%s\n",course[i][j].c_str());
			}
		}
	}
	return 0;
} 

在这里插入图片描述

总结

  这道题和1039相映成趣,刚好是其逆过程,不过这道题比起1039可简单多了,而且考察点也大相径庭,或者出PAT的那帮人,也挺无聊的吧。

评论 4
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值