A1042. Shuffling Machine(洗牌机)

Time Limit:400ms           Memory Limit:65 536KB 难度指数:★★☆☆☆

题目描述

Shuffling is a procedure used to randomize a deck of playing cards. Because standard shuffling techniques are seen as weak, and in order to avoid “inside jobs” where employees collaborate with gamblers by performing inadequate shuffles, many casinos employ automatic shuffling machines. Your task is to simulate a shuffling machine.

The machine shuffles a deck of 54 cards according to a given random order and repeats for a given number of times. It is assumed that the initial status of a card deck is in the following order:

S1, S2, …, S13, H1, H2, …, H13, C1, C2, …, C13, D1, D2, …, D13, J1, J2

where “S” stands for “Spade”, “H” for “Heart”, “C” for “Club”, “D” for “Diamond”, and “J” for “Joker”. A given order is a permutation of distinct integers in [1, 54]. If the number at the i-th position is j, it means to move the card from position i to position j. For example, suppose we only have 5 cards: S3, H5, C1, D13 and J2. Given a shuffling order {4, 2, 5, 3, 1}, the result will be: J2, H5, D13, S3, C1. If we are to repeat the shuffling again, the result will be: C1, H5, S3, J2, D13.

输入格式

Each input file contains one test case. For each case, the first line contains a positive integer K (<= 20) which is the number of repeat times. Then the next line contains the given order. All the numbers in a line are separated by a space.

每个输入文件包含一个测试用例,对于每一个测试用例,第一行包含一个正整数k(<=20),表示重复次数,然后下一行包含给定的顺序。在一行上的所有数字都用一个空格隔开。

输出格式

For each test case, print the shuffling results in one line. All the cards are separated by a space, and there must be no extra space at the end of the line.

对于每个测试用例,将结果打印在一行中,所有的牌都用空格隔开,行的末端没有多余的空格。

输入样例

2
36 52 37 38 3 39 40 53 54 41 11 12 13 42 43 44 2 4 23 24 25 26 27 6 7 8 48 49 50 51 9 10 14 15 16 5 17 18 19 1 20 21 22 28 29 30 31 32 33 34 35 45 46 47

输出样例

S7 C11 C10 C12 S1 H7 H8 H9 D8 D9 S11 S12 S13 D10 D11 D12 S3 S4 S6 S10 H1 H2 C13 D2 D3 D4 H6 H3 D13 J1 J2 C1 C2 C3 C4 D1 S5 H5 H11 H12 C6 C7 C8 C9 S2 S8 S9 H10 D5 D6 D7 H4 H13 C5

题意

有54张牌,编号为1~54。初始按照编号从小到大排列,从左至右分别是13张S、13张H、13张C、13张D和2张J,初始排列:S1,S2,……,S13,H1,H2,……,H13,C1,C2,……,C13,D1,D2,……,D13,J1,J2。
   接下来,程序操作将改变牌的位置k次,比如给定了5张牌是[S3,H5,C1,D13,J2],然后给定操作序列{4,2,5,3,1},k=2,因此第一次变换就会把S3放到4号位、把H5放到2号位……,那么序列变成了[J2,H5,D13,S3,C1],进行第二次变换,J2放到4号位、H5放到2号位……,结果变成[C1,H5,S3,J2,D13]。

思路

   步骤 1:由于题目给出的操作直接明确了每个位置上的牌的在操作后的位置,因此不妨设置两个数组start[]和end[],分别用来存放执行操作前的牌序与执行操作后的牌序(即start[i]表示操作前第i个位置牌的编号)。这样在每次操作中就可以把数组start[]中的每一个位置的牌号存放到数组end[]的对应转换位置中,然后用数组end[]覆盖数组start[]来给下一次操作使用。这样当执行k轮操作后,数组start[]中即存放了最终的牌序。
   步骤 2:由于输出需要用花色来表示,且每种花色有13张牌,因此不妨使用char型数组mp[] = {S,H,C,D,J}来建立编号与花色的关系。例如,假如当前的牌号为x, 那么mp[(x-1)/13]即为这张牌对应的花色(即1~13号为‘S’,14~26号为‘H’等),而(x-1)%13 + 1即为它所在的花色下的编号。

注意

1.这道题目很好地利用了整除和取余,要注意推导和学习这种方法;
2.要注意输出格式,不允许在一行的末尾多出一个空格,否则在正式编程中会返回“格式错误”

代码
#include<stdio.h>

const int N = 54;
char mp[5] = {'S','H','C','D','J'};
int start[N+1],end[N+1],next[N+1];

int main(){
    int k,i;

    //-----------输入部分-------------
    scanf("%d",&k);
    for(i = 1;i <= N ;i++){
        start[i] = i;     //初始化牌的编号,1~54号
    }
    for(i =1;i <= N;i++){
        scanf("%d",&next[i]);  //输入每个位置上的牌在操作后的位置
    }

    //-----------处理部分-------------
    for(int step = 0;step < k;step++){
        for(int i=1;i<=N;i++){
            end[next[i]] = start[i];//把start数组第i个位置牌的编号存放于end数组的第next[i]个位置
        }
        for(i = 1;i <= N;i++){
            start[i] = end[i];  //把end数组赋值给start数组供下一次的操作使用
        }
    }

    //-----------输出部分------------
    for(i =1;i <= N;i++){
        if(i != 1)
            printf(" ");  //控制输出格式
        start[i]--;
        printf("%c%d",mp[start[i] / 13],start[i] % 13 + 1);
    }
    return 0;
}

这里写图片描述

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值