String painter

16 篇文章 0 订阅

 

String painter

Time Limit: 5000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 8471    Accepted Submission(s): 4127


 
Problem Description
There are two strings A and B with equal length. Both strings are made up of lower case letters. Now you have a powerful string painter. With the help of the painter, you can change a segment of characters of a string to any other character you want. That is, after using the painter, the segment is made up of only one kind of character. Now your task is to change A to B using string painter. What’s the minimum number of operations?
 
 
Input
Input contains multiple cases. Each case consists of two lines:
The first line contains string A.
The second line contains string B.
The length of both strings will not be greater than 100.
 
 
Output
A single line contains one integer representing the answer.
 
 
Sample Input
zzzzzfzzzzz
abcdefedcba
abababababab
cdcdcdcdcdcd
 
 
Sample Output
6 7
有第一个串,变成第二个串,需要最少多少步操作,每次操作可以把一个任意区间涂成一样的字符
#include <iostream>
#include <cstdio>
#include <string>
#include <cmath>
#include <algorithm>
#include <cstring>
#define rush() int T;cin>>T;while(T--)
#define sf(a) scanf("%d\n",&a)
#define sft(a,b) scanf("%d%d",&a,&b)
#define go(a) while(scanf("%d",&a)!=EOF)
#define ms(a,b) memset(a,b,sizeof a)
#define rep(i,a,b) for(int i=a;i<=b;i++)
#define pf(a) printf("%.8lf",a)
#define E 1e-8
using namespace std;
typedef long long ll;
const double pi=acos(-1.0);
const int inf=0x3f3f3f3f;
const int idata=100+5;

int n,m,t;
int i,j,k;
int a[idata],dp[idata][idata];
char ch[idata];

int main()
{
    /*cin.tie(0);
    iostream::sync_with_stdio(false);*/
    while(cin>>ch+1)
    {
        char temp[idata];
        cin>>temp+1;
        int len=strlen(ch+1);
        ms(dp,0);
        for(i=1;i<=len;i++) dp[i][i]=1;
        for(int u=2;u<=len;u++)
        {
            for(i=1,j=u;j<=len;i++,j++)
            {
                dp[i][j]=dp[i][j-1]+1;
                for(k=i;k<j;k++)
                {
                    if(temp[k]==temp[j])
                        dp[i][j]=min(dp[i][j],dp[i][k-1]+dp[k][j-1]);
                }
            }
        }
        for(i=1;i<=len;i++)
        {
            a[i]=dp[1][i];
            if(ch[i]==temp[i])
            {
                if(i==1) a[i]=0;
                else a[i]=a[i-1];
            }
            for(j=1;j<=i;j++)
            {
                a[i]=min(a[i],a[j]+dp[j+1][i]);
            }
        }
        cout<<a[len]<<endl;
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值