1408: 数塔
时间限制: 1 Sec 内存限制: 32 MB提交: 3 解决: 2
[ 提交][ 状态][ 讨论版]
题目描述
在讲述DP算法的时候,一个经典的例子就是数塔问题,它是这样描述的:
有如下所示的数塔,要求从顶层走到底层,若每一步只能走到相邻的结点,则经过的结点的数字之和最大是多少?
已经告诉你了,这是个DP的题目,你能AC吗?
输入
输入数据首先包括一个整数C,表示测试实例的个数,每个测试实例的第一行是一个整数N(1 <= N <= 100),表示数塔的高度,接下来用N行数字表示数塔,其中第i行有个i个整数,且所有的整数均在区间[0,99]内。
输出
对于每个测试实例,输出可能得到的最大和,每个实例的输出占一行。
样例输入
1
5
7
3 8
8 1 0
2 7 4 4
4 5 2 6 5
样例输出
30
从最底下开始遍历,找出状态转移方程:
tower[i][j] += max(tower[i + 1][j], tower[i + 1][j + 1])
#include <iostream>
#include <string.h>
using namespace std;
const int MAXX = 105;
int tower[MAXX][MAXX];
int max(int x, int y){
if (x > y)return x;
return y;
}
int main(){
int t, n;
cin >> t;
while (t--){
cin >> n;
memset(tower, 0, sizeof(tower));
for (int i = 0; i < n; i++){
for (int j = 0; j < n; j++){
if (i >= j)cin >> tower[i][j];
}
}
for (int i = n - 1; i >= 0; --i)
for (int j = 0; j <= i; ++j)
tower[i][j] += max(tower[i + 1][j], tower[i + 1][j + 1]);
printf("%d\n",tower[0][0]);
}
}