SDUT OJ 数据结构实验之链表七:单链表中重复元素的删除

数据结构实验之链表七:单链表中重复元素的删除

Time Limit: 1000MS  Memory Limit: 65536KB
Problem Description
按照数据输入的相反顺序(逆位序)建立一个单链表,并将单链表中重复的元素删除(值相同的元素只保留最后输入的一个)。
Input
第一行输入元素个数n; 
第二行输入n个整数。
Output
第一行输出初始链表元素个数; 
第二行输出按照逆位序所建立的初始链表;
第三行输出删除重复元素后的单链表元素个数;
第四行输出删除重复元素后的单链表。
Example Input
10
21 30 14 55 32 63 11 30 55 30
Example Output
10
30 55 30 11 63 32 55 14 30 21
7
30 55 11 63 32 14 21

Hint

#include<bits/stdc++.h>
using namespace std;
struct node
{
    int data;
    struct node *next;
};
int n;
void Delete(struct node *head)
{
    struct node *tail,*p,*q;
    tail=head->next;
    while(tail)
    {
        p=tail;
        q=tail->next;
        while(q)
        {
            if(tail->data==q->data)
            {
                p->next=q->next;
                q=q->next;
                n--;
            }
            else
            {
                p=p->next;
                q=q->next;
            }
        }
         tail=tail->next;
    }
}
int main()
{
    cin>>n;
    struct node *head,*tail,*p;
    head=new node;
    head->next=NULL;
    tail=head;
    for(int i=0; i<n; i++)
    {
        p=new node;
        cin>>p->data;
        p->next=head->next;
        head->next=p;
    }
    cout<<n<<endl;
    for(p=head->next; p; p=p->next)
    {
        if(p->next==NULL)
        {
            cout<<p->data<<endl;
        }
        else
            cout<<p->data<<" ";
    }
    Delete(head);
    cout<<n<<endl;
    for(p=head->next; p; p=p->next)
    {
        if(p->next==NULL)
        {
            cout<<p->data<<endl;
        }
        else
            cout<<p->data<<" ";
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值