【PAT刷题甲级】1009.Product of Polynomials

1009 Product of Polynomials (25 分)

This time, you are supposed to find A×B where A and B are two polynomials.

Input Specification

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:
在这里插入图片描述
where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that
在这里插入图片描述

Output Specification

For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.

Sample Input

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output

3 3 3.6 2 6.0 1 1.6

题意

计算两个多项式相乘的积,显示非零项个数K,以及按指数降序方式输出指数以及其对应的系数。

代码

#include <iostream>
using namespace std;

int main() {
	float c1[1001]= {0};	//存放第一个多项式的指数i对应的系数
	float c2[1001]= {0};	//存放第二个多项式的指数i对应的系数
	float c[2001]= {0};		//存放结果多项式的指数i对应的系数
	int k1,k2,n;	//非零项个数,n为指数
	float a; 		//系数
	scanf("%d",&k1);	
	for(int i=0; i<k1; i++) {	//输入第一个多项式 
		scanf("%d %f",&n,&a);
		c1[n] = c1[n] + a;
	}
	scanf("%d",&k2);
	for(int i=0; i<k2; i++) {	//输入第二个多项式
		scanf("%d %f",&n,&a);
		c2[n] = c2[n] + a;
	}
	int exp=0,k=0;
	for(int i=0; i<1001; i++) {	//计算多项式相乘
		if(c1[i]!=0) {
			for(int j=0; j<1001; j++) {
				if(c2[j]!=0) {
					exp = i + j;
					c[exp] = c[exp] + c1[i] * c2[j];
				}
			}
		}
	}
	for(int i=0; i<2001; i++) {	//统计非零项 
		if(c[i]!=0)
			k++;
	}
	printf("%d",k);
	for(int i=2000;i>=0;i--)	//逆序输出系数数组中的非零项 
	{
		if(c[i]!=0)
			printf(" %d %.1f",i,c[i]);
	}
	return 0;
}

参考柳神代码(https://blog.csdn.net/liuchuo/article/details/52109341)改进版本

#include <iostream>
using namespace std;

int main() {
	float c[1001]= {0};			//存放第一个多项式的指数i对应的系数
	float res[2001]= {0};		//存放结果多项式的指数i对应的系数
	int k1,k2,k=0,n;			//非零项个数,n为指数
	float a; 	//系数
	scanf("%d",&k1);
	for(int i=0; i<k1; i++) {	//输入第一个多项式
		scanf("%d %f",&n,&a);
		c[n] = c[n] + a;
	}
	scanf("%d",&k2);
	for(int i=0; i<k2; i++) {	//输入第二个多项式并计算结果多项式 
		scanf("%d %f",&n,&a);
		for(int j=0; j<1001; j++) {
			res[j+n] += c[j] * a;
		}
	}
	for(int i=0; i<2001; i++) {	//统计非零项
		if(res[i]!=0)	k++;
	}
	printf("%d",k);
	for(int i=2000; i>=0; i--) {//逆序输出系数数组中的非零项
		if(res[i]!=0)
			printf(" %d %.1f",i,res[i]);
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值