【PAT刷题甲级】1100.Mars Numbers

1100 Mars Numbers (20 分)

People on Mars count their numbers with base 13:

Zero on Earth is called “tret” on Mars.
The numbers 1 to 12 on Earth is called “jan, feb, mar, apr, may, jun, jly, aug, sep, oct, nov, dec” on Mars, respectively.
For the next higher digit, Mars people name the 12 numbers as “tam, hel, maa, huh, tou, kes, hei, elo, syy, lok, mer, jou”, respectively.
For examples, the number 29 on Earth is called “hel mar” on Mars; and “elo nov” on Mars corresponds to 115 on Earth. In order to help communication between people from these two planets, you are supposed to write a program for mutual translation between Earth and Mars number systems.

Input Specification

Each input file contains one test case. For each case, the first line contains a positive integer N (<100). Then N lines follow, each contains a number in [0, 169), given either in the form of an Earth number, or that of Mars.

Output Specification

For each number, print in a line the corresponding number in the other language.

Sample Input

4
29
5
elo nov
tam

Sample Output

hel mar
may
115
13

题意

火星上的数字实行13进制,0-12分别是"tret, jan, feb, mar, apr, may, jun, jly, aug, sep, oct, nov, dec" ,高位12位分别是"tam, hel, maa, huh, tou, kes, hei, elo, syy, lok, mer, jou",比如26就是火星上的"hel","elo nov"代表地球上的115。
给出一些字符,进行火星数字和地球数字的相互转换。

代码

#include <iostream>
#include <string>
#include <map>
#include <cctype>
using namespace std;
map <string,int> m;
int main() {
	string s1[13]= {"tret","jan", "feb", "mar", "apr", "may", "jun", "jly", "aug", "sep", "oct", "nov", "dec"};
	string s2[13]= {"tret","tam", "hel", "maa", "huh", "tou", "kes", "hei", "elo", "syy", "lok", "mer", "jou"};
	for(int i=0; i<13; i++) {
		m[s1[i]]=i;
		m[s2[i]]=i*13;
	}
	int n,t;
	string s;
	scanf("%d\n",&n);
	for(int i=0; i<n; i++) {
		getline(cin,s);
		if(isalpha(s[0])) {
			int j=0;
			string low,high;
			while(s[j]!=' ' && j<s.length())	j++;
			if(j!=s.length()) {
				low = s.substr(j+1);
				high = s.substr(0,j);
				t = m[high] + m[low];
				printf("%d\n",t);
			} else {
				printf("%d\n",m[s]);
			}
		} else {
			t=stoi(s);
			if(t%13==0) {
				printf("%s\n",s2[t/13].c_str());
			} else {
				if(t/13!=0)	printf("%s ",s2[t/13].c_str());
				printf("%s\n",s1[t%13].c_str());
			}
		}
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值