【PAT刷题甲级】1030.Travel Plan

1030 Travel Plan (30 分)

A traveler’s map gives the distances between cities along the highways, together with the cost of each highway. Now you are supposed to write a program to help a traveler to decide the shortest path between his/her starting city and the destination. If such a shortest path is not unique, you are supposed to output the one with the minimum cost, which is guaranteed to be unique.

Input Specification

Each input file contains one test case. Each case starts with a line containing 4 positive integers N, M, S, and D, where N (≤500) is the number of cities (and hence the cities are numbered from 0 to N−1); M is the number of highways; S and D are the starting and the destination cities, respectively. Then M lines follow, each provides the information of a highway, in the format:

City1 City2 Distance Cost

where the numbers are all integers no more than 500, and are separated by a space.

Output Specification

For each test case, print in one line the cities along the shortest path from the starting point to the destination, followed by the total distance and the total cost of the path. The numbers must be separated by a space and there must be no extra space at the end of output.

Sample Input

4 5 0 3
0 1 1 20
1 3 2 30
0 3 4 10
0 2 2 20
2 3 1 20

Sample Output

0 2 3 3 40

题意

最短路径问题,求两个城市间距离最短且花费最少的路径。
(Dijkstra+DFS)
PS:套用算法笔记的模板即可,很好用!希望自己考前能记住~

代码

#include <iostream>
#include <algorithm>
#include <vector>
using namespace std;
int n,m,st,ed;
int G[510][510],d[510],cost[510][510];
vector<int> pre[510];
vector<int> path,temppath;	//最优路径、临时路径
bool vis[510]= {false};
const int inf=0x3fffffff;
int opt=inf;	//第二梯度最佳值,路径长度
void Dijkstra(int st) {
	fill(d,d+510,inf);
	d[st]=0;
	for(int i=0; i<n; i++) {
		int u=-1,minn=inf;
		for(int j=0; j<n; j++) {
			if(vis[j]==false && d[j]<minn) {
				u=j;
				minn=d[j];
			}
		}
		if(u==-1)	return;
		vis[u]=true;
		for(int v=0; v<n; v++) {
			if(vis[v]==false && G[u][v]!=inf) {
				if(d[u]+G[u][v]<d[v]) {
					d[v]=d[u]+G[u][v];
					pre[v].clear();
					pre[v].push_back(u);	//v的前驱是v
				} else if(d[u]+G[u][v]==d[v]) {
					pre[v].push_back(u);
				}
			}
		}
	}
}
void DFS(int v) {	//v为当前访问结点
	if(v==st) {		//递归边界
		temppath.push_back(v);
		int value=0;	//临时路径第二标尺的值
		//边权之和
		for(int i=temppath.size()-1; i>0; i--) {
			int id=temppath[i],idNext=temppath[i-1];
			value += cost[id][idNext];
		}
		if(value<opt) {
			opt=value;
			path=temppath;
		}
		temppath.pop_back();	//将刚加入的节点删除
		return;
	}
	temppath.push_back(v);	//将当前访问结点加入temppath最后面
	for(int i=0; i<pre[v].size(); i++) {
		DFS(pre[v][i]);
	}
	temppath.pop_back();	//遍历完所有的前驱结点,将当前节点v删除
}
int main() {
	scanf("%d%d%d%d",&n,&m,&st,&ed);
	fill(G[0],G[0]+510*510,inf);
	fill(cost[0],cost[0]+510*510,inf);
	int a,b,dis,c;
	for(int i=0; i<m; i++) {
		scanf("%d%d%d%d",&a,&b,&dis,&c);
		G[a][b]=G[b][a]=dis;
		cost[a][b]=cost[b][a]=c;
	}
	Dijkstra(st);
	DFS(ed);
	for(int i=path.size()-1; i>=0; i--) {
		printf("%d ",path[i]);
	}
	printf("%d %d",d[ed],opt);
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值